Closed Bug 488547 Opened 12 years ago Closed 10 years ago

do runtime perf check of best way to blit to screen

Categories

(Core :: Widget: Win32, defect)

All
Windows CE
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: vlad, Unassigned)

References

Details

In bug 484864, it looks like there's a variety of approaches we can take in getting the results of our rendering to the screen on Windows CE.  Different devices have different characteristics, including perf differences and support differences.

The different approaches we'd have to figure out how/where to do a runtime test for are, so far:

  - StretchDIBits with a 32bpp DIB source
  - StretchDIBits with a 24bpp DIB source, converting from 32->24 beforehand
  - Using DirectDraw

Note that this isn't really specific to Windows CE; something like this is probably helpful on the desktop as well, because on some platforms using cairo image surfaces and StretchDIBits is probably going to be as fast or faster (generally, on any newer hardware, or on Vista or later) than using win32 surfaces.
Duplicate of this bug: 488912
WinCE/Windows Mobile support has been removed from the main build system, Spidermonkey, mobile installer, in-app updater and so on (see bug 614720, bug 554087 and all their dependants). Until such point where MS decide to release a Windows Phone 7 NDK and the decision is made to port to that platform, this is WONTFIX.

Filter bugmail on WinCEMassWONTFIX.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.