[Meta] Remove support for WinCE/Windows Mobile

RESOLVED FIXED

Status

Core Graveyard
Tracking
--
trivial
RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: Matheus Kerschbaum, Unassigned)

Tracking

({meta})

Trunk
All
Windows CE
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre
Build Identifier: 

See Bug 600714 comment 0.

Reproducible: Always
(Reporter)

Updated

7 years ago
Depends on: 614721
Depends on: 473687
Blocks: 519240
Version: unspecified → Trunk
Blocks: 600454
Status: UNCONFIRMED → NEW
Ever confirmed: true
Seems weird to remove WinCE support before we're sure we won't be able to do a Windows Phone 7 port.

Comment 2

7 years ago
I think there are some places that I don't mind removing (like the ddraw bits), but a huge removal of wince might be an overkill.
Depends on: 644743
Depends on: 644801
(Reporter)

Updated

7 years ago
Depends on: 647389

Updated

7 years ago
Depends on: 648508
(Reporter)

Updated

6 years ago
Depends on: 649078

Comment 3

6 years ago
Adding bug 386760, since the rewrite there removes all of the old WinCE updater code.

(In reply to comment #1)
> Seems weird to remove WinCE support before we're sure we won't be able to do a
> Windows Phone 7 port.

(In reply to comment #2)
> I think there are some places that I don't mind removing (like the ddraw bits),
> but a huge removal of wince might be an overkill.

I would have thought that even if MS finally release a Windows Phone 7 NDK, and even if the decision is made to port to it; the platform changes will be significant enough compared to WinCE 6 that most of the current WinCE specific code would be redundant anyway? (Especially given that a lot of it is ancient hackery working around older WinCE OS/compiler bugs and limitations, which one would hope would no longer exist on Windows Phone 7...or at least in different forms?)
No longer blocks: 519240, 600454
Keywords: meta
OS: All → Windows CE
Summary: Remove support for WinCE → [Meta] Remove support for WinCE/Windows Mobile
In the case of the updater (bug 386760), it would likely just work with Windows Phone 7 and there wouldn't be new API's. I mainly removed it because it was difficult to support WinCE/WinMo while optimizing the code. I suspect it will be the same eslewhere as well.

Updated

6 years ago
Depends on: 651622

Updated

6 years ago
Depends on: 651657

Updated

6 years ago
Depends on: 652029

Updated

6 years ago
Depends on: 622840

Updated

6 years ago
Depends on: 652445

Updated

6 years ago
Depends on: 652506
Depends on: 653765

Updated

6 years ago
Depends on: 654463

Updated

6 years ago
Depends on: 654472

Updated

6 years ago
Depends on: 654504

Updated

6 years ago
Depends on: 654552

Updated

6 years ago
Depends on: 654594

Updated

6 years ago
Depends on: 654600

Updated

6 years ago
Depends on: 654611

Updated

6 years ago
Depends on: 654716

Updated

6 years ago
Depends on: 654718

Updated

6 years ago
Depends on: 654719

Updated

6 years ago
Depends on: 654723

Updated

6 years ago
Depends on: 654732

Updated

6 years ago
Depends on: 654736

Updated

6 years ago
Depends on: 654737

Updated

6 years ago
Depends on: 655010

Updated

6 years ago
Depends on: 655011

Updated

6 years ago
Depends on: 655039

Updated

6 years ago
Depends on: 655176
Is Fennec dead?

Comment 6

6 years ago
(In reply to comment #5)
> Is Fennec dead?

No, Fennec is the code name for the mobile version of Firefox, which is being actively developed for Maemo and Android (https://wiki.mozilla.org/Mobile/Fennec), so Fennec itself isn't dead.

What is being discussed here is WinCE/Windows Mobile platform support, which was the initial platform for Fennec, but is no longer supported by it - thanks to Microsoft's decision to not release an NDK for Windows Phone 7 (http://blog.pavlov.net/2010/03/22/stopping-development-for-windows-mobile/).

Updated

6 years ago
Depends on: 655473

Updated

6 years ago
Depends on: 655475

Updated

6 years ago
Depends on: 655480

Updated

6 years ago
Depends on: 655488

Updated

6 years ago
Depends on: 655493

Updated

6 years ago
Depends on: 655496

Updated

6 years ago
Depends on: 655498

Updated

6 years ago
Depends on: 655503

Updated

6 years ago
Depends on: 656017

Updated

6 years ago
Depends on: 656187

Updated

6 years ago
Depends on: 664311

Comment 7

6 years ago
Removing dependency on bug 622840, since the WinCE removal parts have landed (http://hg.mozilla.org/mozilla-central/rev/98ef084ded47) even though the rest of the bug was backed out / reopened.

Closing this meta now, since the only remaining instances of:
WINCE
WIN32_WCE 
MOZ_CE
WINMO
...are in upstream code, including NSPR (WONTFIX) & NSS (being dealt with in bug 654611); so nothing left to do here.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 622840
Resolution: --- → FIXED
Depends on: 715210
Depends on: 715559
Depends on: 764266
(Assignee)

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.