remove hardcoded english strings caused by bug 488218

RESOLVED FIXED

Status

()

Firefox
General
P2
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

({fixed1.9.1, late-l10n})

unspecified
fixed1.9.1, late-l10n
Points:
---
Bug Flags:
blocking-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [geo])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

9 years ago
in bug 488218, we used US-en hard coded strings.  we need to localize these.
(Assignee)

Comment 1

9 years ago
Created attachment 373338 [details] [diff] [review]
patch v.1
Attachment #373338 - Flags: review?
(Assignee)

Updated

9 years ago
Flags: blocking-firefox3.5?
(Assignee)

Updated

9 years ago
Attachment #373338 - Flags: review? → review?(gavin.sharp)

Comment 2

9 years ago
Comment on attachment 373338 [details] [diff] [review]
patch v.1

>+geolocation.learnMore=Learn More...

... should this be using hellip?
(Assignee)

Comment 3

9 years ago
can i just replace "..." with "…"
(Assignee)

Comment 5

9 years ago
Created attachment 373349 [details] [diff] [review]
patch v.2
Attachment #373338 - Attachment is obsolete: true
Attachment #373349 - Flags: review?
Attachment #373338 - Flags: review?(gavin.sharp)
(Assignee)

Comment 6

9 years ago
axel tells me that the localization note should be directly above the entity.  i can fix that before I push
(Assignee)

Updated

9 years ago
Whiteboard: [geo]
Flags: blocking-firefox3.5? → blocking-firefox3.5+
Keywords: late-l10n
Priority: -- → P2
(Assignee)

Updated

9 years ago
Attachment #373349 - Flags: review? → review?(gavin.sharp)
Attachment #373349 - Flags: review?(gavin.sharp) → review+
Comment on attachment 373349 [details] [diff] [review]
patch v.2

You forgot the nsBrowserGlue changes in this diff, but r=me assuming they're the same as in attachment 373338 [details] [diff] [review], and with the l10n note moved per Axel.
(Assignee)

Comment 8

9 years ago
http://hg.mozilla.org/mozilla-central/rev/be9560b1ed35
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

9 years ago
Created attachment 373660 [details] [diff] [review]
inclusive patch

carrying forward gavin's r+
Attachment #373349 - Attachment is obsolete: true
Attachment #373660 - Flags: review+
Attachment #373660 - Flags: approval1.9.1?
Comment on attachment 373660 [details] [diff] [review]
inclusive patch

>+# LOCALIZATION NOTE (geolocation.learnMore): Use the unicode ellipsis char, \u2026,
>+# or use "..." unless \u2026 doesn't suit traditions in your locale.

Shouldn't this be "if" instead of "unless"?

As far as I understand the tree rules, this doesn't need approval after the beta freeze, since it's blocking...
Yes, it should be "if". The existing comments in intl.properties also have this problem.
Whiteboard: [geo] → [geo][will approve after b4 cutoff]
Comment on attachment 373660 [details] [diff] [review]
inclusive patch

We're actually gonna change some strings, I'll come back around to specify ...
Attachment #373660 - Flags: ui-review-
Attachment #373660 - Flags: approval1.9.1?
Attachment #373660 - Flags: approval1.9.1-
(Assignee)

Comment 13

9 years ago
beltzner, lets open up a new bug for that work.

Comment 14

9 years ago
Beltzner, Doug commented to possibly fork the string changes to a different bug, but you're not on CC so you probably didn't get that request.
Comment on attachment 373660 [details] [diff] [review]
inclusive patch

OK, I'll file the followup to change the strings.
Attachment #373660 - Flags: ui-review-
Attachment #373660 - Flags: approval1.9.1-
Attachment #373660 - Flags: approval1.9.1+
Please land this on branch.
Whiteboard: [geo][will approve after b4 cutoff] → [geo]
Those are different strings, as far as I can see. nsBrowserGlue.js still has the hardcoded string:
http://mxr.mozilla.org/mozilla1.9.1/source/browser/components/nsBrowserGlue.js#1100
(Assignee)

Comment 20

9 years ago
ah, right.  pretty sure mike also wanted these.

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/f573430102e6

Updated

9 years ago
Keywords: fixed1.9.1
(Assignee)

Comment 21

9 years ago
fwiw, the only string difference between 1.9.1 and mc related to geolocation is the access key for the "remember this decision":

checkbox.setAttribute("accesskey", browserBundle.GetStringFromName("geolocation.remember.accesskey"));

gavin, do we want to ask for another localization change here?
If we've already made changes for this milestone, making one more probably won't hurt. On its own, the accesskey functionality is probably not worth the effort.

Comment 23

9 years ago
Adding one more string will make us slip the RC1 schedule now, I don't think that's acceptible. Making this change after RC1 will delay whichever RC would come after that, not sure if we're willing to take that either.
(In reply to comment #23)
> Adding one more string will make us slip the RC1 schedule now

One additional string on top of the two we've already added will make us slip RC1?

Comment 25

9 years ago
Of course. Frankly, I don't know where I had to pick you up in explaining why.
Just to be clear, I meant "the two we've already added for this milestone". Doug pushed two string additions on the 15th. Now it's the 17th, and we're talking about potentially adding one more. Are you saying that localizers have already all updated their locales to add the 2 strings and gone through signoff, so adding one more will force them to go through another round?

Comment 27

9 years ago
Yes. Code freeze is supposed to be on Wednesday, and the usual concept is to have a l10n freeze at least over the weekend, with opt-in thread open. Which is http://groups.google.com/group/mozilla.dev.l10n/browse_frm/thread/0f7ae76ae424e870#.
You need to log in before you can comment on or make changes to this bug.