XMLHTTPRequest Randomly Fails with Status Code 0 During Reload/Refresh and/or Multiple Requests

RESOLVED INCOMPLETE

Status

()

--
critical
RESOLVED INCOMPLETE
10 years ago
10 days ago

People

(Reporter: steve, Unassigned)

Tracking

1.9.0 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120413], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8

We have used FireFox 1 and 2 for years as our default browser for our web-based business system that we wrote in-house. When trying to upgrade to FireFox 3, we started getting all kinds of XMLHTTPRequest errors, and it's an issue with the status code returning 0 and the xmlhttprequest actually failing to send data.

I've put an exagerated example up on the following link

http://homepage.mac.com/zacware/firefox_bug/firefox_bug.htm

NOTE: JQuery and Prototype also have the same problem. The code I included was simply so the file could run without any external libraries being needed

FireFox 1 and 2 don't have the problem. Neither does Safari. It's only FireFox 3 (we no longer use IE at all so that's not an issue whether or not it works there)

Reproducible: Always

Steps to Reproduce:
We have used FireFox 1 and 2 for years as our default browser for our web-based business system that we wrote in-house. When trying to upgrade to FireFox 3, we started getting all kinds of XMLHTTPRequest errors, and it's an issue with the status code returning 0 and the xmlhttprequest actually failing to send data.

We've been too busy to deal with it. But it's been 6 months since we first tried version 3 and the bug is still there so I've taken the time to finally explore the issue.

I've put an exagerated example up on the following link

http://homepage.mac.com/zacware/firefox_bug/firefox_bug.htm

NOTE: JQuery and Prototype also have the same problem. The code I included was simply so the file could run without any external libraries being needed

FireFox 1 and 2 don't have the problem. Neither does Safari. It's only FireFox 3 (we no longer use IE at all so that's not an issue whether or not it works there)

Comment 1

10 years ago
I also experienced this problem in Firefox 3.0.11. It was easiest to trigger my making the server side respond really slowly and then hitting escape to stop loading the page.

Comment 2

10 years ago
This is apparently not limited to OS X.
Ubuntu Bug from Edwin Grubbs (Comment #1):
https://bugs.launchpad.net/bugs/394912

He said this happened in Firefox 3.5 as well.
I get similar behavior with Firefox, Safari and Chrome when testing 
http://homepage.mac.com/zacware/firefox_bug/firefox_bug.htm
X number alerts.

The testcase is strange. It assumes that the next page can somehow access the
previous page.
And on FF2.0.0.x accessing XMLHttpRequest.status in the event listener gives NS_ERROR_NOT_AVAILABLE error.

My guess is that the page relied on unintended behavior.

Comment 5

10 years ago
I can confirm on FFox 3.5.2, as packaged on Ubuntu Karmic. It does not happen always (in my case), and I have not yet determined why.
(Reporter)

Comment 6

10 years ago
If it helps, here's a simpler example using jQuery that exhibits the same behavior as my original example.

http://homepage.mac.com/zacware/xhr_bug/xhr_bug.htm

Comment 7

10 years ago
This seems to have been caused by the patch for Bug 424212

Here is the changeset in mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/151522b6da28

Comment 8

10 years ago
We have the same kind of problem in a XUL app, when some XMLHTTP requests are launched rapidly, we have "sometimes" an error.

Observing data with wireshark shows a [TCP Previous segment lost] and a [TCP Out-Of-Order] for the awaited response. Maybe it could help

Comment 9

9 years ago
I have this as well, on Firefox 3.5.3 under both Windows 2000 and Windows Vista.
I have an application that makes an XMLHttpRequest every 5 seconds.  The page alternates between waiting for the 5-second timer callback and waiting for the XMLHttpRequest callback.  When I leave the page by clicking on an image, the XMLHttpRequest callback is sometimes called with state=4, status=0. 

The changeset at "http://hg.mozilla.org/mozilla-central/rev/151522b6da28" looks like it explains this situation.
Version: unspecified → 3.0 Branch
Reporter, Firefox 4.0.1 has been released, and it features significant improvements over previous releases. Can you please update to Firefox 4.0.1 or later, and retest your bug? Please also create a fresh profile (
http://support.mozilla.com/kb/Managing+profiles), update your plugins (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and Operating system to the latest versions available. 

If you still continue to see this issue, please comment. If you do not, please close this bug as RESOLVED > WORKSFORME

filter: prefirefox4uncobugs
looks like op is not here around, if you can reproduce, feel free to reopen it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [testday-20120413]
Component: General → DOM: Mozilla Extensions
Product: Firefox → Core
QA Contact: general → general
Version: 3.0 Branch → 1.9.0 Branch
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core

Comment 12

5 years ago
Ok it seems that this is still an issue in Firefox 25.0.1 (on OS X).

I am using https://github.com/PixelsCommander/OnlineJS which sends XMLHTTPRequests to a server to check if the server is online. Sometimes the return status is 0. About 5 of 100 request the status is 0.

Other browsers are working without any problems.

Maybe someone can confirm this issue.
(In reply to Marcus Fritze from comment #12)
> Ok it seems that this is still an issue in Firefox 25.0.1 (on OS X).
> 
> I am using https://github.com/PixelsCommander/OnlineJS which sends
> XMLHTTPRequests to a server to check if the server is online. Sometimes the
> return status is 0. About 5 of 100 request the status is 0.
> 
> Other browsers are working without any problems.
> 
> Maybe someone can confirm this issue.

hey Marcus, can you file a new bug with proper step to reproduce from here https://bugzilla.mozilla.org/enter_bug.cgi
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → INCOMPLETE

Comment 14

5 years ago
Thanks for the quick response, I created a new issue: Bug 942942
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.