With a very small crashset, Topcrasher report missing some crashes

RESOLVED DUPLICATE of bug 501228

Status

RESOLVED DUPLICATE of bug 501228
10 years ago
7 years ago

People

(Reporter: alqahira, Unassigned)

Tracking

Trunk
All
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

We just added Breakpad support in Camino, so we currently have a very small set of crash reports on Socorro (for Camino 2.0b3pre, I believe the number to be 4).

When I run http://crash-stats.mozilla.com/topcrasher/byversion/Camino/2.0b3pre I get 3 crashes, libgkgfx.dylib, @0x0 | CoreFoundation, and Flash Player (note the Flash Player crash has appeared in the Topcrash report since last night).

When I run http://crash-stats.mozilla.com/query/query?do_query=1&product=Camino&version=Camino%3A2.0b3pre&platform=mac&date=&range_value=1&range_unit=weeks&query_search=signature&query_type=exact&query= ("Filter all crashes" on the main page), I also get 3 crashes: libgkgfx.dylib, Camino, and Flash Player (the @0x0 | CoreFoundation crash is older than one week).  The Camino crash had been reported last night by the time the Flash Player crash was reported, because I looked at them both.

Note here that the "Camino" crash was filed ~10 hrs before the Flash Player crash, yet the Camino crash has not yet shown up in the Topcrashers report.  There is only one of each crash.

Note also that if I extend the number of weeks (to 2) I search in "Filter all reports", I get a total of 7 crashes (each signature has only one crash), including the @0x0 | CoreFoundation crash that *is* appearing in the Topcrashers report.

I guess I'm just confused why, given that all crashes (signatures) exist exactly once, 

1) a crash that occurred/was reported yesterday afternoon is not yet appearing in the topcrashers report while one that was reported yesterday evening is

2) one of the four crashes that are older than a week *are* appearing in the Topcrashers report, but none of the other older ones are.

That seems like a bug to me; if all crashes have equal frequency within the Topcrashers reporting period (whatever that is, but in this case it shouldn't matter), then all crashes should appear in the Topcrashers report.
I'm pretty sure topcrash reports update once a day, but I don't remember at what time. On them, I believe the date that's given is inaccurate. i.e., now I see "Below are the top 3 crashers as of 2009-04-02 23:24:02." and that might be inaccurate. I'm pretty sure the topcrash report is only the last week.

As of this moment, I see 3 crashes in the topcrash list, and 4 in the query. The additional one in the query happened today at 11:36. That all seems right to me.
Pretty sure this is bug 501228 :P
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501228
(Assignee)

Updated

7 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.