(TUnit) xpcshell-tests test_getTypeFromExtension_with_empty_Content_Type.js leaks

VERIFIED FIXED in mozilla1.9.2a1

Status

defect
VERIFIED FIXED
11 years ago
3 years ago

People

(Reporter: sgautherie, Assigned: Paolo)

Tracking

({fixed1.9.1, memory-leak})

Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed1.9.1b4], )

Attachments

(1 attachment)

Bug 484579 comment 21:
{
From  Serge Gautherie (:sgautherie)   2009-04-19 06:02:32 PDT

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1239905472.1239917703.3668.gz&fulltext=1
Linux mozilla-central unit test on 2009/04/16 11:11:12

Leaked: 3328
}
Flags: wanted1.9.2?
The leaks observed in test_getTypeFromExtension_with_empty_Content_Type.js
are common to all the three exthandler tests, and are caused by the directory
service provider not being unregistered in head_handlerService.js.

This essential patch should solve the issue. There is still a leak in
test_punycodeURIs.js, but it seems to be caused by the nsEnvironment::Set
calls. I had a look at the code but can't find the leak at a glance, it's
better that someone else looks at it:

http://mxr.mozilla.org/mozilla-central/source/xpcom/threads/nsEnvironment.cpp#163
Assignee: nobody → paolo.02.prg
Attachment #373576 - Flags: review?(sdwilsh)
(In reply to comment #1)
> common to all the three exthandler tests

That is good news!

> caused by the nsEnvironment::Set calls.

Must be bug 203764 ;-|
Blocks: 470235
Status: NEW → ASSIGNED
Comment on attachment 373576 [details] [diff] [review]
Fix most leaks in exthandler tests
[Checkin: Comment 4 & 5]

r=sdwilsh

Technically, you need sr, but I'm not sure if anyone will actually care if you don't get it here.
Attachment #373576 - Flags: review?(sdwilsh) → review+
Keywords: checkin-needed
Comment on attachment 373576 [details] [diff] [review]
Fix most leaks in exthandler tests
[Checkin: Comment 4 & 5]


http://hg.mozilla.org/mozilla-central/rev/02d8a0a5f71f
Attachment #373576 - Attachment description: Fix most leaks in exthandler tests → Fix most leaks in exthandler tests [Checkin: Comment 4]
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: wanted1.9.2? → in-testsuite+
Resolution: --- → FIXED
Whiteboard: [needs 1.9.1 landing]
Target Milestone: --- → mozilla1.9.2a1
Comment on attachment 373576 [details] [diff] [review]
Fix most leaks in exthandler tests
[Checkin: Comment 4 & 5]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/4c6223415d6f
Attachment #373576 - Attachment description: Fix most leaks in exthandler tests [Checkin: Comment 4] → Fix most leaks in exthandler tests [Checkin: Comment 4 & 5]
V.Fixed, per FF and TB tinderboxes.

Thanks Paolo!
Status: RESOLVED → VERIFIED
Whiteboard: [needs 1.9.1 landing] → [fixed1.9.1b4]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.