Closed Bug 470235 Opened 11 years ago Closed 11 years ago

(TUnit) xpcshell-tests test_handlerService.js and test_punycodeURIs.js leak

Categories

(Core Graveyard :: File Handling, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.9.2a1

People

(Reporter: sgautherie, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: fixed1.9.1, memory-leak, Whiteboard: [fixed1.9.1b4] [Fixed by bugs "470241" and 489078])

_tests\xpcshell-simple\test_uriloader_exthandler\unit
test_handlerService.js
test_punycodeURIs.js

See bug 456414.
Flags: wanted1.9.1?
Depends on: 469523
No longer depends on: 456414
Confirmed by
{
http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird/1238183877.1238186339.30647.gz&fulltext=1
Linux comm-central check on 2009/03/27 12:57:57
}
OS: Windows 2000 → All
Confirmed by
{
http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird3.0/1238257155.1238260151.7894.gz&fulltext=1
MacOSX 10.4 comm-1.9.1 check on 2009/03/28 09:19:15
}
Ftr, test_handlerService.js leak was greatly reduced yesterday: see bug 470241 comment 3.
Depends on: 470241
(In reply to comment #3)

Previous leak was 11-15 kB, new is 2-4 kB.

NB: This did not regress with bug 470241 comment 4.
Depends on: 489078
Ftr,
Bug 489078 comment 1:
{
[...] test_punycodeURIs.js [...] caused by the nsEnvironment::Set
calls.

http://mxr.mozilla.org/mozilla-central/source/xpcom/threads/nsEnvironment.cpp#163
}
URL: 203764
URL: 203764
Depends on: 203764
Bug 489078 fixed (as much as possible) the remaining leak(s):
FF leak decreased to '3 nsStringBuffer' only, as expected.
TB/Linux too, TB/MacOSX to None(!), TB/Windows is red atm(...).

V.Fixed + fixed1.9.1
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: wanted1.9.1? → in-testsuite+
Keywords: fixed1.9.1
Hardware: x86 → All
Resolution: --- → FIXED
Summary: test_handlerService.js and test_punycodeURIs.js leak → (TUnit) xpcshell-tests test_handlerService.js and test_punycodeURIs.js leak
Whiteboard: [fixed1.9.1b4] [Fixed by bugs "470241" and 489078]
Target Milestone: --- → mozilla1.9.2a1
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.