Closed Bug 489920 Opened 11 years ago Closed 6 years ago

Intermittent test_localStorageOriginsSchemaDiffs.html | localStorage different domains; Test timed out

Categories

(Core :: DOM: Core & HTML, defect, major)

x86
All
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sgautherie, Assigned: mayhemer)

References

()

Details

(Keywords: intermittent-failure)

{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1240440830.1240446213.2051.gz
Linux comm-central unit test on 2009/04/22 15:53:50
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1240524522.1240529209.27846.gz
Linux comm-central unit test on 2009/04/23 15:08:42

*** 41897 INFO TEST-PASS | /tests/dom/tests/mochitest/localstorage/test_localStorageOriginsPortDiffs.html | Y null in the master, expected null got null
*** 41899 INFO Running /tests/dom/tests/mochitest/localstorage/test_localStorageOriginsSchemaDiffs.html...

command timed out: 300 seconds without output, killing pid 22876
process killed by signal 9
program finished with exit code -1
}
Flags: wanted1.9.1?
Are you 100% sure the output is complete? I had problems with timeouts, logs were not complete (there is a pending bug about it). I will try to reproduce it. Is it only timing out on SeaMonkey or on other products too?
(In reply to comment #1)
> Are you 100% sure the output is complete? I had problems with timeouts, logs

I'm not sure what you mean, but you can check the logs by yourself!

> were not complete (there is a pending bug about it). I will try to reproduce

Might be good to make this bug depend on that other one...

> it. Is it only timing out on SeaMonkey or on other products too?

I'm rather sure I've only noticed it on this SM box so far,
I don't know about Firefox.
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1241259550.1241264113.26042.gz
Linux comm-central unit test on 2009/05/02 03:19:10
Whiteboard: [orange]
(In reply to comment #2)
> > Are you 100% sure the output is complete? I had problems with timeouts, logs
> I'm not sure what you mean, but you can check the logs by yourself!

Oh, I'm sorry if I was rude: I didn't get your comment right :-(

I meant I had copied all that is available.
I agree there are bugs (I'm working on, btw) about log generation,
but there is no way (atm) to know whether this is happening or not :-|

*****

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1243572730.1243576470.28188.gz
Linux comm-central unit test on 2009/05/28 21:52:10
Looks like this happened on Windows Firefox as well

WINNT 5.2 mozilla-central unit test on 2009/06/23 12:21:08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1245784868.1245792419.30996.gz&fulltext=1

42597 INFO Running /tests/dom/tests/mochitest/localstorage/test_localStorageOriginsSchemaDiffs.html...

command timed out: 300 seconds without output
program finished with exit code 1
elapsedTime=1439.703000
TinderboxPrint: mochitest-plain
...
buildbot.slave.commands.TimeoutError: command timed out: 300 seconds without output
OS: Linux → All
Summary: [SeaMonkey, Linux] mochitest-plain: test_localStorageOriginsSchemaDiffs.html times out intermittently → mochitest-plain: test_localStorageOriginsSchemaDiffs.html times out intermittently
Flags: wanted1.9.2?
Flags: wanted1.9.1?
Flags: wanted1.9.1.x?
I just hit this on a Windows Try-Server:
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1247716232.1247723177.14304.gz
Version: 1.9.1 Branch → Trunk
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Are there any known problems of posting messages (postMessage) between secure (https) and unsecure (http) pages?
status1.9.1: --- → ?
Flags: wanted1.9.1.x?
Severity: normal → major
Whiteboard: [orange] → [test which aborts the suite] [orange]
http://tinderbox.mozilla.org/Firefox/1272838659.1272841447.27434.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-3/5 on 2010/05/02 15:17:39
s: talos-r3-snow-010
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273113261.1273115655.12524.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-3/5 on 2010/05/05 19:34:21
s: talos-r3-snow-012
Which isn't a timeout, but is now bug 607418.
The issue here is that connection to https: sub-iframe in the tests is untrusted and gets stuck.  Unfortunatelly, the screenshot doesn't show the untrust reason.

According the log it seems that authorities were imported and ssltunnel listens on the 4443 port with pgo cert, as expected.

This might be a problem with ssltunnel or some hidden problem with certificate verification.
(Please check comment 25)
Seems not to appear for two months.  Closing, please reopen if appears again.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
(In reply to TinderboxPushlog Robot from comment #28)
> alqahira at ardisson dot org
> https://tbpl.mozilla.org/php/getParsedLog.php?id=7758777&tree=Firefox3.6
> Linux mozilla-1.9.2 test mochitests on 2011-12-05 13:23:14

This turned out to actually be bug 531590, so you can continue to ignore this bug as having resolved itself WFM :)
Given the timing, comment 22, comment 23 and comment 26 (with a stale parent pushed to try) would also have been bug 531590
status1.9.1: ? → ---
Flags: wanted1.9.2?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [test which aborts the suite] [orange] → [test which aborts the suite]
Summary: mochitest-plain: test_localStorageOriginsSchemaDiffs.html times out intermittently → Intermittent test_localStorageOriginsSchemaDiffs.html | localStorage different domains; Test timed out
Whiteboard: [test which aborts the suite]
Component: DOM: Mozilla Extensions → DOM
Status: REOPENED → RESOLVED
Closed: 9 years ago6 years ago
Resolution: --- → WORKSFORME
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.