Closed Bug 490105 Opened 13 years ago Closed 13 years ago

Long strings in autoconfig need to wrap

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: philor, Assigned: bwinton)

References

Details

(Whiteboard: [m6])

Attachments

(2 files)

From bug 422814 comment 134:

[[[
Failure to log in breaks the dialog. With the goats@/goats, hit "Create
account" and the failure to log in puts up a "FAIL" dialog, but also shoves the
right side of the main window over a little with an "Username or password
invalid" (which I bet is then a huge shove with a language where that has to be
longer), and shoves the "Edit" and "Create Account" buttons halfway out of
sight, because the "Configuration could not be verified -- is the username or
password wrong?" string is too long and not wrapping, which probably means that
things are broken for more than just that one string in more verbose locales
than English.
]]]

where the STR for goats are

1. File - New - Mail Account (Quick Setup)
2. Name = goats, email = goats@harborside.com, password = goats (I really hope the account doesn't exist)
3. Next, then when the servers are discovered, Create account
Flags: blocking-thunderbird3?
Duplicate of this bug: 490142
This sounds like it should block.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b3
Duplicate of this bug: 490419
This is probably mine with bug 490097
Assignee: nobody → clarkbw
Status: NEW → ASSIGNED
Whiteboard: [m6][needs patch]
assigning this over to bwinton who's going to rock out where I'm obviously not
Assignee: clarkbw → bwinton
Attached image Wrapped error message.
Ta-da!
Well, that ended up being a small change.

clarkbw gave a ui-review+ over IRC.
Attachment #382374 - Flags: review?(philringnalda)
Comment on attachment 382374 [details] [diff] [review]
[checked in] A small patch to get the error message to wrap.

Yup, looks good. I thought we still needed to wrap the one on the left side, but when I tried with a l10n-approximation with the longest words I could find for username, password and invalid, I figured it looked better pushing than it would with two words on one line and one on the next.
Attachment #382374 - Flags: review?(philringnalda) → review+
http://hg.mozilla.org/comm-central/rev/68e9bf53a79c
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [m6][needs patch] → [m6]
Attachment #382374 - Attachment description: A small patch to get the error message to wrap. → [checked in] A small patch to get the error message to wrap.
You need to log in before you can comment on or make changes to this bug.