Last Comment Bug 490153 - test_not-opener.html | Should not be able to navigate popup's popup by submitting form or by calling window.open. - got 1, expected 2
: test_not-opener.html | Should not be able to navigate popup's popup by submit...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Justin Lebar (not reading bugmail)
:
Mentors:
http://tinderbox.mozilla.org/showlog....
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2009-04-25 12:24 PDT by Graydon Hoare :graydon
Modified: 2013-03-25 02:25 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix intermittent orange in test_not-opener.html. (2.98 KB, patch)
2011-04-26 08:54 PDT, Justin Lebar (not reading bugmail)
jonas: review+
Details | Diff | Review

Description Graydon Hoare :graydon 2009-04-25 12:24:27 PDT
Random orange, WINNT 5.2 tracemonkey unit test on 2009/04/24 11:47:49.

Perhaps similar to bug 451090?
Comment 1 Robert Strong [:rstrong] (use needinfo to contact me) 2009-05-21 13:38:13 PDT
Just happened on mozilla-1.9.1

Linux mozilla-1.9.1 unit test on 2009/05/21 12:18:17

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1242933497.1242937706.30709.gz
Comment 2 Daniel Holbert [:dholbert] (largely AFK until June 28) 2009-06-12 13:30:13 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.0/1244835360.1244838205.19988.gz
Linux fx-linux-1.9-slave09 dep unit test on 2009/06/12 12:36:00
Comment 3 Serge Gautherie (:sgautherie) 2009-08-24 10:40:24 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1251124592.1251134135.1173.gz
WINNT 5.2 comm-1.9.1 unit test on 2009/08/24 07:36:32
Comment 5 Daniel Holbert [:dholbert] (largely AFK until June 28) 2009-10-23 09:46:44 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256314971.1256315828.3603.gz
Linux mozilla-central test mochitests-2/5 on 2009/10/23 09:22:51
Comment 7 Phil Ringnalda (:philor) 2009-11-04 12:46:28 PST
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257356406.1257357562.8758.gz
Linux mozilla-central test mochitests-2/5 on 2009/11/04 09:40:06
Comment 8 Daniel Holbert [:dholbert] (largely AFK until June 28) 2009-11-06 22:51:09 PST
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1257567967.1257570988.23001.gz
Linux mozilla-1.9.2 test mochitests on 2009/11/06 20:26:07
Comment 11 Blake Kaplan (:mrbkap) (please use needinfo!) 2009-12-14 16:18:22 PST
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1260830382.1260833376.24034.gz
Comment 13 Nochum Sossonko [:Natch] 2009-12-24 13:28:04 PST
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1261685888.1261688649.4619.gz
Linux mozilla-1.9.2 test mochitests
Comment 14 Treeherder Robot 2010-05-08 05:45:27 PDT
dao%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273320566.1273321995.31979.gz
Linux mozilla-central debug test mochitests-2/5, Started 14:09, finished 14:34, took 26mins

s: moz2-linux-slave25
245 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
246 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
247 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 15 Treeherder Robot 2010-05-21 12:07:09 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1274466596.1274467858.6900.gz
Linux mozilla-central debug test mochitests-2/5, Started 11:29, finished 11:51, took 22mins

s: moz2-linux-slave20
245 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
246 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
247 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 16 Treeherder Robot 2010-06-03 06:32:46 PDT
peterv%propagandism.org
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275569637.1275570899.25917.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/06/03 05:53:57

s: moz2-linux-slave28
245 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
246 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
247 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 17 Treeherder Robot 2010-06-04 13:55:50 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275683284.1275684530.9050.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/06/04 13:28:04

s: moz2-linux-slave28
245 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
246 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
247 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 18 Treeherder Robot 2010-06-04 13:57:20 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275683284.1275684530.9050.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/06/04 13:28:04

s: moz2-linux-slave28
245 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
246 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
247 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 19 Treeherder Robot 2010-06-04 17:12:12 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1275694778.1275696050.29598.gz
Linux mozilla-central debug test mochitests-2/5 on 2010/06/04 16:39:38

s: moz2-linux-slave28
245 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
246 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
247 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 20 Treeherder Robot 2010-06-17 03:14:36 PDT
dao%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1276764183.1276767195.6031.gz
Linux mozilla-1.9.2 test mochitests on 2010/06/17 01:43:03

s: moz2-linux-slave48
42343 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
42344 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 21 Treeherder Robot 2010-09-20 14:16:29 PDT
ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1285015487.1285016172.956.gz
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitests-2/5 on 2010/09/20 13:44:47

s: talos-r3-leopard-017
280 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
281 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
282 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 22 Treeherder Robot 2010-10-25 21:51:14 PDT
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1288062989.1288066210.15477.gz
OS X 10.5.2 mozilla-1.9.2 test mochitests on 2010/10/25 20:16:29

s: moz2-darwin9-slave57
42730 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
42731 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
42732 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 23 Treeherder Robot 2010-11-17 00:55:04 PST
jfkthame%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1289977703.1289980741.29283.gz
OS X 10.5.2 mozilla-1.9.2 test mochitests on 2010/11/16 23:08:23

s: moz2-darwin9-slave54
42742 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - 1 should equal 2
42743 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - 1 should equal 2
42744 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - 1 should equal 2
Comment 24 Treeherder Robot 2011-03-01 07:07:53 PST
Olli.Pettay%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1298988437.1298991597.20740.gz
OS X 10.5.2 mozilla-1.9.2 test mochitests on 2011/03/01 06:07:17

s: moz2-darwin9-slave50
42728 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - 1 should equal 2
42729 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - 1 should equal 2
42730 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - 1 should equal 2
Comment 25 Treeherder Robot 2011-04-20 13:21:49 PDT
justin.lebar+bug%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303328791.1303329588.8583.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitests-2/5 on 2011/04/20 12:46:31

s: talos-r3-fed64-006
307 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
308 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
309 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 26 Treeherder Robot 2011-04-20 13:22:32 PDT
rnewman%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303328791.1303329588.8583.gz
Rev3 Fedora 12x64 mozilla-central opt test mochitests-2/5 on 2011/04/20 12:46:31

s: talos-r3-fed64-006
307 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
308 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
309 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 27 Treeherder Robot 2011-04-21 00:33:28 PDT
jfkthame%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1303369880.1303370630.20948.gz
Rev3 Fedora 12 mozilla-aurora opt test mochitests-2/5 on 2011/04/21 00:11:20

s: talos-r3-fed-007
308 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
309 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 28 Justin Lebar (not reading bugmail) 2011-04-26 08:54:55 PDT
Created attachment 528319 [details] [diff] [review]
Fix intermittent orange in test_not-opener.html.

I think the problem is that with the off-main-thread HTML parser, data: URIs are not loaded synchronously.  This patch may fix things.
Comment 29 Justin Lebar (not reading bugmail) 2011-04-27 16:23:40 PDT
http://hg.mozilla.org/mozilla-central/rev/f85e9589bd11
Comment 30 Treeherder Robot 2012-12-20 21:16:32 PST
rnewman
https://tbpl.mozilla.org/php/getParsedLog.php?id=18152959&tree=Mozilla-Beta
Android Armv6 Tegra 250 mozilla-beta opt test mochitest-2 on 2012-12-20 20:40:33
slave: tegra-166

55840 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
55841 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
55842 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 31 Treeherder Robot 2013-01-04 13:43:16 PST
kats
https://tbpl.mozilla.org/php/getParsedLog.php?id=18474615&tree=Try
Android Tegra 250 try opt test mochitest-3 on 2013-01-04 12:55:40
slave: tegra-102

16377 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
16378 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2
Comment 32 Treeherder Robot 2013-03-25 02:25:38 PDT
ewong
https://tbpl.mozilla.org/php/getParsedLog.php?id=21049650&tree=Mozilla-Aurora
Android Armv6 Tegra 250 mozilla-aurora opt test mochitest-3 on 2013-03-25 00:42:11
slave: tegra-250

16950 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by calling window.open. - got 1, expected 2
16951 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by submitting form. - got 1, expected 2
16952 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/navigation/test_not-opener.html | Should not be able to navigate popup's popup by targeted hyperlink. - got 1, expected 2

Note You need to log in before you can comment on or make changes to this bug.