Closed Bug 490241 Opened 12 years ago Closed 12 years ago

[autoconfig] Account created with bad imap and pop address

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cantalou.thunderbird, Assigned: BenB)

References

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090426 Lightning/1.0pre Shredder/3.0b3pre

I created a mail account at http://www.gmx.fr
When I write this bug, gmx.fr is not listed in http://live.mozillamessaging.com/autoconfig/
On this website, when I write this bug there is:
[TXT]	gmx.de	19-Jan-2009 12:02 	3.1K
[TXT]	gmx.de imap	19-Jan-2009 12:02 	3.1K
[TXT]	gmx.net	19-Jan-2009 12:02 	3.1K

Based on GMX.fr documentation, servers address are:
*  POP3 Server: pop.gmx.com
* SMTP Server: mail.gmx.com (for POP and IMAP)
* IMAP4 Server: imap.gmx.com

Autoconfig created the account with:
* SMTP Server: mail.gmx.fr | Port: 587
* IMAP4 Server: imap.gmx.fr | Port: 143

Moreover the AutoConfig directly creates an IMAP account
It could be also a POP and I did not get any pop-up message to choose

Reproducible: Always

Steps to Reproduce:
1. File => New => Mail account (Quick Setup)
2. Key-in Name+Email+Password
3. Click on Create
Actual Results:  
Autoconfig created the account with:
* SMTP Server: mail.gmx.fr | Port: 587
* IMAP4 Server: imap.gmx.fr | Port: 143

Account works but, based on GMX documentation, it should have been with gmx.com  in the server address.
I assume that gmx also run gmx.fr servers.

Expected Results:  
Autoconfig should have:
1. Ask if a pop3 or an IMAP account should have been created
2. Create the account with:
* SMTP Server: mail.gmx.com | Port: 25
* IMAP4 Server: imap.gmx.com | Port: I don't find in the documentation

I've 4 mail accounts set-up:
2 @gmail.com
1 @yahoo.com but not working
1 @gmx.de

Shredder is installed for less than a week with a new profile on this computer
Attached image Quick SetUp Screen Shot
Attached image GMX Documentation
Attached image GMX Documentation
I think these issues are per design. (One issue per bug please.)

Port 587 is the smtp client submission port (read bug 383877), used since some ISPs may block port 25.

And IMAP vs POP: most users wouldn't know what to choose, so we choose imap since it's way cooler ;)
Two mistakes in my initial post:

1. When I say "account works but...", it means that I can receive and send mail from and to this account.
But I still don't understand how autoconfig guessed server and port.

2. I've 4 mail accounts set-up:
2 @gmail.com
1 @yahoo.com but not working because Yahoo.com request to pay to have pop3 access
1 @gmx.FR

Another comment:
On http://live.mozillamessaging.com/autoconfig/
domain gmx.fr is not included even within TXT files which deal with:
gmx.de
gmx.net
gmx.ch
gmx.at
gmx.li
(In reply to comment #0)

> Based on GMX.fr documentation, servers address are:
> *  POP3 Server: pop.gmx.com
> * SMTP Server: mail.gmx.com (for POP and IMAP)
> * IMAP4 Server: imap.gmx.com
> 
> Autoconfig created the account with:
> * SMTP Server: mail.gmx.fr | Port: 587
> * IMAP4 Server: imap.gmx.fr | Port: 143

Work:Java ludo$ nslookup imap.gmx.fr 
Server:		208.67.222.222
Address:	208.67.222.222#53

Non-authoritative answer:
imap.gmx.fr	canonical name = imap.gmx.com.
Name:	imap.gmx.com
Address: 74.208.5.70

so the .fr domain of gmx is an alias of the .com that's why it's what you see in the configuration.
> Moreover the AutoConfig directly creates an IMAP account
> It could be also a POP and I did not get any pop-up message to choose

By default imap is choosen over pop - this is by design - you can change that normaly before creating the account - if you can't please raise a new bug.

Both the issues you reported are not issues (changing from imap to pop would be one thought). Thanks a lot for the time you took trying to test the new feature. I'm going to close this bug as invalid - because I think It would be way clearer to file just a new bug over the fact that you can't switch from imap to pop (I have not tested that myself though)

Cantalou if the above explainations are not clear - drop me a mail, ok ?
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
The autoconfig does not fail, but we should provide an ISP config.

I should:
- add gmx.fr domain to the "gmx.de" and "gmx.de imap" config file
- copy "gmx imap" to all domains listed in there.
Did that. Marking FIXED.

cantalou, please try again to configure your account. You should now get imap.gmx.net as incoming server, which is the correct one.
Assignee: nobody → ben.bucksch
OS: Windows XP → All
Hardware: x86 → All
Resolution: INVALID → FIXED
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.