Closed Bug 490272 Opened 12 years ago Closed 12 years ago

Sender contains GBK characters can't be read

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 468351

People

(Reporter: ye_hq, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

14.60 KB, text/plain; charset="gb2312"
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0 beta2

When sender of mail (From) contains GBK characters, then the sender can't be read, but there is no problem in Thunderbird 2.0.0.21

Reproducible: Always
Please attach a sample mail (save as .eml)
Keywords: regression
Reporter, can you reply as in comment #1?
Anyway I think is the same problem described in bug #415368 and bug #401358
Whiteboard: closeme 2009-09-18
Attached file sender missed
Sorry about my carelessness for so long. This issue doesn't bother me much actually so I have forgot it at all. I have attached a sample and wish it would be helpful.
Attachment #398563 - Attachment mime type: message/rfc822 → text/plain;chaset=gb2312
Attachment #398563 - Attachment mime type: text/plain;chaset=gb2312 → text/plain;chaset=utf-8
Attachment #398563 - Attachment mime type: text/plain;chaset=utf-8 → text/plain; chaset="gb2312"
Attachment #398563 - Attachment mime type: text/plain; chaset="gb2312" → text/plain; charset="gb2312"
(In reply to comment #4)
> sender missed

Changed mime-type of the attachment to text/plain; charset=gb2312

> From: "网易" <music@service.netease.com>
> To: 网易用户
Wrong header case. Raw binary of GB2312 is put in message header without encoding.

DUP of Bug 468351 if POP3(local mail folder). DUP of Bug 513472 if IMAP.
Are you using pop or imap ?
Whiteboard: closeme 2009-09-18
Yes, I am using pop

pop.163.com
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468351
You need to log in before you can comment on or make changes to this bug.