All users were logged out of Bugzilla on October 13th, 2018

Non-ascii characters and comma in name make Thunderbird split the sender address incorrectly

RESOLVED DUPLICATE of bug 254519

Status

RESOLVED DUPLICATE of bug 254519
10 years ago
8 years ago

People

(Reporter: ferrix, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10
Build Identifier: 2.0.0.21 (20090409)

When I receive mail where the sender is of the form "Lastname, Firstname" and the last name contains Finnish umlaut letters ä and ö, the sender is parsed into simply Lastname.

Example:

Järvinen, Jukka <j@j.com> is shown as:

Message window: "Järvinen" and "Jukka <j@j.com>"
Reply window: "Järvinen"
Index: "Järvinen"
Header: "From: =?iso-8859-1?Q?J=E4rvinen=2C_Jukka?= <j@j.com>"

Affected version: 2.0.0.21 (20090409)

This happens when the mail is sent from Exchange. The only apparent difference in the From header sent from Thunderdird is that the real name field is enclosed into =22 quotations.

Reproducible: Always

Steps to Reproduce:
1. Set your sender name as Järvinen, Jukka in Exchange 2003
2. Send email to you Thunderbird

Or

1. Go to Edit -> Account Settings -> Manage Identities
2. Add an identity with =?iso-8859-1?Q?J=E4rvinen=2C_Jukka?= as your name (that is what Exchange sets it to)
3. Send email to yourself
Actual Results:  
- The sender is listed in index as just Järvinen.
- The message window shows the sender as two separate addresses: Järvinen and Jukka. Järvinen has no address part.
- Replies to the mail go to Järvinen which in turn is an invalid address.

I was unable to repeat the last result with Thunderbird probably due to some additional headers unset by 


Expected Results:  
The sender address should be shown as "Järvinen, Jukka" everywhere. The default recipient of the reply should have a valid email address. The comma in the address is encoded as =2C in the address, so it should not be interpreted as a real comma.

Actually URL-enconding any letter whatsoever before the comma, does the trick. For example =?iso-8859-1?Q?Mys=65lf=2C_Not=? seems to have come from Myself.
(Reporter)

Comment 1

10 years ago
It is apparently possible to make just about any arbitrary string show up as the first sender address as long as there is a comma, escaped letters and no quotes.
By the way, as I wrote in bug 444771 comment #2, I'm sure that we user can't reach bug 254519 unless we already know bug 254519.
Although bug summary of bug 254519 is absolutely correct technically, I believe bug summary of this bug by you is better for us, non-developer(user/tester).
DUP per comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519

Comment 5

9 years ago
TB do not enclose name, if cn contains special chars, this cause the described error, bug affect 2.0.0.X version on Windows and Linux both.


Thunderbird/Icedove Header

To: :: Test :: Error <mymail@example.com>

Evolution Header

To: ":: Test :: Error" <mymail@example.com>

Alessandro
You need to log in before you can comment on or make changes to this bug.