(NS_ERROR_FILE_DIR_NOT_EMPTY) [nsIFile.remove] error during software update

RESOLVED DUPLICATE of bug 512651

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 512651
9 years ago
8 years ago

People

(Reporter: marcia, Unassigned)

Tracking

(Depends on: 1 bug)

1.9.1 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Seen while updating my Shiretoko nightly using 10.6. It seemed while applying the update I had to go through the steps twice - Download the update, wait for it to apply, but then it did not seem to apply. This was in the console:

4/29/09 3:14:02 PM	[0x0-0xf00f].org.mozilla.firefox	*** AUS:SVC General:cleanUpUpdatesDir - failed to remove update directory: /Users/marcia/Desktop/1.9.1/Shiretoko.app/Contents/MacOS/updates/0 - This is almost always bad. Exception = [Exception... "Component returned failure code: 0x80520014 (NS_ERROR_FILE_DIR_NOT_EMPTY) [nsIFile.remove]"  nsresult: "0x80520014 (NS_ERROR_FILE_DIR_NOT_EMPTY)"  location: "JS frame :: file:///Users/marcia/Desktop/1.9.1/Shiretoko.app/Contents/MacOS/components/nsUpdateService.js :: cleanUpUpdatesDir :: line 478"  data: no]
The error in the console is possibly due to bug 473385.

You state, "t seemed while applying the update I had to go through the steps twice". Can you provide more details?
(Reporter)

Comment 2

9 years ago
rstrong: unfortunately I do not recall specifically what happened right before the error, but it was something like this:

1. Running one of the latest Shiretoko nightlies, went and manually checked for updates to the 4/29 build.
2. I see the update downloading.

[this is when it gets fuzzy...]

I thought I restarted the browser, but then I noticed when I checked for updates again there was another update. I am not entirely sure I was running yesterday's build (likely a build from a few days ago because of the all hands).  So I will repeat the same steps tomorrow and see if the error occurs again, and this time I will give you more precise STR.
That sounds like you may have had an update download for a previous nightly already in progress and then updated to the next available nightly. You would have seen an error page otherwise.

The remaining issue is likely bug 473385
Depends on: 473385
(Reporter)

Comment 4

9 years ago
Here is what happened today when I updated on the same machine:

1. Running the 20090429 build, I came to the machine and the update to 20090430 had already downloaded. I restarted to apply the update.
2. The partial update failed, and it went out to find the full update.
3. After the update applied I have the same error in the console that is described in Comment 0.
So, the summary for this bug is for the directory removal failure which is likely 473385.

Not sure what is going on with the partial update failure. Please file a separate bug for this and attach the log files (e.g. last-update.log, active-update.xml, and updates.xml) from before downloading / applying the full update.
We no longer remove the directory due to a WinCE bug. This was fixed in bug 512651 so resolving dupe
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 512651
You need to log in before you can comment on or make changes to this bug.