lessen the write access checks during startup and remove final-ui-startup observer

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Toolkit
Application Update
P2
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

(Blocks: 1 bug)

1.9.2 Branch
mozilla1.9.3a1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(status1.9.2 beta2-fixed)

Details

(Whiteboard: [ts])

Attachments

(1 attachment, 5 obsolete attachments)

I believe this was initially coded this way for simplicity and this can at the very least be improved.
Note: this may need to leverage bug 512650
Whiteboard: [ts]
Created attachment 396886 [details] [diff] [review]
patch in progress rev1
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Bug 512994 removes one of the deletions so adding dependency
Depends on: 512994
Created attachment 398823 [details] [diff] [review]
patch in progress rev2
Attachment #396886 - Attachment is obsolete: true
Bug 512994 makes it so we don't delete / recreate the updates/0 directory on startup so updating summary.
Summary: lessen the deletions / recreations of the updates and updates/0 directories during startup → lessen the write access checks during startup
Created attachment 405102 [details] [diff] [review]
patch in progress rev3
Attachment #398823 - Attachment is obsolete: true
Created attachment 405137 [details] [diff] [review]
patch in progress rev4
Attachment #405102 - Attachment is obsolete: true
I'm going to remove the workaround for bug 497578 which is fixed by bug 496335 so adding dependency.
Depends on: 496335
Summary: lessen the write access checks during startup → lessen the write access checks during startup and remove final-ui-startup observer
Created attachment 405151 [details] [diff] [review]
patch rev1
Attachment #405137 - Attachment is obsolete: true
Attachment #405151 - Flags: review?(dtownsend)
Dave, I just noticed that the following is not used so I'd like to remove it at the same time as I check this in
/**
 * Gets a File URL spec for a nsIFile
 * @param   file
 *          The file to get a file URL spec to
 * @returns The file URL spec to the file
 */
function getURLSpecFromFile(file) {
  var ioServ = Cc["@mozilla.org/network/io-service;1"].
               getService(Ci.nsIIOService);
  var fph = ioServ.getProtocolHandler("file").
            QueryInterface(Ci.nsIFileProtocolHandler);
  return fph.getURLSpecFromFile(file);
}
Per bug 311965 comment #42 it looks like this will reduce nsUpdateService.js TS by about 70ms on Maemo.

from 10/8 with this patch and the patch from Bug 520526 applied
nsUpdateService.js : 78+2+7+2+30    = 119

from 10/2
nsUpdateService.js : 138+2+6+9+33   = 188ms

from 7/21
nsUpdateService.js : 109+2+28+36+25 = 200ms
Blocks: 459117
Attachment #405151 - Flags: review?(dtownsend) → review+
Created attachment 405559 [details] [diff] [review]
patch as checked in
Attachment #405151 - Attachment is obsolete: true
Attachment #405559 - Flags: review+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/64e1e88b4d77
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Drivers, according to Taras' logs this reduces TS on Maemo from somewhere between 45ms and 65ms so requesting blocking.
Flags: blocking1.9.2?
Priority: -- → P2
Comment on attachment 405559 [details] [diff] [review]
patch as checked in

Drivers, this has baked for a while now and improves TS at least on Fennec and possibly around .5% on desktop.
Attachment #405559 - Flags: approval1.9.2?
Flags: blocking1.9.2?
Comment on attachment 405559 [details] [diff] [review]
patch as checked in

a191=beltzner
Attachment #405559 - Flags: approval1.9.2? → approval1.9.2+
Pushed to mozilla-1.9.2 - forgot to add the a=beltzner in the comment :(
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/b9c0c7338779
status1.9.2: --- → final-fixed
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.3a1
Version: unspecified → 1.9.2 Branch
Duplicate of this bug: 490711
Depends on: 538372
You need to log in before you can comment on or make changes to this bug.