Closed Bug 491150 Opened 11 years ago Closed 9 years ago

canvas arc with negative radius doesn't throw INDEX_SIZE_ERR

Categories

(Core :: Canvas: 2D, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b11

People

(Reporter: krit, Assigned: Ms2ger)

References

(Blocks 1 open bug, )

Details

(Keywords: dev-doc-complete, html5)

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10

An arc() with a negative radius doesn't throw an INDEX_SIZE_ERR (http://www.whatwg.org/specs/web-apps/current-work/#dom-context-2d-arc) but current versions of Opera or WebKit do.
This was discussed on the WhatWg mailing list http://www.nabble.com/Canvas---Exception-on-arc-with-negative-radius-td22748785.html and Hixie opposed to change the specification.

Reproducible: Always

Steps to Reproduce:
1. Visit the link above in Opera and Firefox
2. Move the molecules around

Actual Results:  
Circles stay in FF

Expected Results:  
Circles go away in Opera an throw the error but stay in FF
Component: General → Layout: Canvas
Product: Firefox → Core
QA Contact: general → layout.canvas
Patch to raise exception specified by spec - also, there's a simple testcase at http://philip.html5.org/tests/canvas/suite/tests/2d.path.arc.negative.html
Attachment #380619 - Flags: review?(vladimir)
Duplicate of this bug: 630068
Assignee: nobody → wesongathedeveloper
Blocks: 622842
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Version: unspecified → Trunk
Status: NEW → ASSIGNED
Attached patch Patch v2 (obsolete) — Splinter Review
Actually, this needs a test change.
Assignee: wesongathedeveloper → Ms2ger
Attachment #380619 - Attachment is obsolete: true
Attachment #508471 - Flags: review?(roc)
Attachment #380619 - Flags: review?(vladimir)
Thanks!
Attachment #508471 - Attachment is obsolete: true
Flags: in-testsuite+
Pushed http://hg.mozilla.org/mozilla-central/rev/263e4f35b797 but note the bug number in the patch was wrong.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Oops, sorry about that.
Target Milestone: --- → mozilla2.0b11
Added note to:

https://developer.mozilla.org/en/DOM/CanvasRenderingContext2D#Notes

And listed the change on Firefox 4 for developers.
You need to log in before you can comment on or make changes to this bug.