Closed Bug 491588 Opened 11 years ago Closed 2 months ago

A kiosk mode in firefox would be much appreciated.

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 158968

People

(Reporter: agr, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

A kiosk mode would be a good feature to add to firefox.

It should be "real" full screen. Not like the F11 options that keep a bar on the top edge of the screen.

Some interesting kiosk mode option could be implemented such as :

- Disable mouse (eg: for keyboard driven applciation)
- Disable keyboard
- Hide mouse pointer when idle
- Disable context menu
- Disable download
...

PS: I saw extensions such as "real kiosk" or "full fullscreen" but they can't be considered as a real kiosk mode such as those found in IE, konqueror and opera.

Reproducible: Always
I am working on a Firefox extension that does disables context menu and download:
http://webconverger.org/kiosk/

However hiding mouse can be done with a X program: http://packages.qa.debian.org/u/unclutter.html

Likewise disabling mouse/keyboard input can be probably tweaked best at the OS level, i.e. with some X parameter.
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 158968
You need to log in before you can comment on or make changes to this bug.