Closed Bug 158968 Opened 18 years ago Closed Last month

command line option for kiosk mode

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
relnote-firefox --- ?
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 + fixed

People

(Reporter: maybespamforandy1, Assigned: mkaply)

References

(Depends on 3 open bugs)

Details

User Story

As a system administrator I want to launch Firefox in kiosk mode, so that Kiosk users can navigate through web pages without Chrome or OS access. The kiosk mode prevents user interaction and activities on the device outside the scope of execution of the browser

Acceptance criteria:
- OS support covers Win7+
- When launched in Kiosk mode, Firefox Runs only in full screen
- All menus, awesome bar and toolbar are not visible as well as tabs. 
---- No X button when you hover to the top of the screen can be seen
---- F11 does not work. 
---- Removes the status bar in the bottom left for progress or for hovering over links.
---- Links that would open a new tab will open in a new tab, but that tab is not navigable directly via the user interface.
- Prevent right click context menu

Numerous features of the kiosk mode are already configurable through policy or command line parameters when launching the browser. We assume that system administrators will be using Firefox as follows:
- Configure accessible domains through policy
- About: pages are disabled through policy
- Launch Firefox through command line with “-private-window URL” parameter so that Firefox is launched in a private Window (Clear the cache, user history and form data between sessions) and pointing to a pre-defined URL
- The homepage is set through policy

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

there should be a command line option to open mozilla in full screen mode.
if you have a site, or file that you commonly open for demonstration purposes,
this would be very handy because you could create a shortcut to  open the file
in full screen mode.

Reproducible: Always
Steps to Reproduce:
1.c
2.
3.
Another example of use : a system for displaying information.

Say you want to display information on a screen using a web page that reloads
itself. So you need to launch the browser in full screen mode when the computer
starts. That's when you need the command line option.
Component: XP Apps → XP Apps: Cmd-line Features
*** Bug 179686 has been marked as a duplicate of this bug. ***
Confirming because of dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 192543 has been marked as a duplicate of this bug. ***
*** Bug 199094 has been marked as a duplicate of this bug. ***
Isn't it possible to get this done at least with chrome url? 

As the next version of Internet Explorer MAY have this, I think this should be
done as command line option.
Blocks: 192543
->defaults.

I don't know why, since I don't even use fullscreen mode, but I'll QA this.
Assignee: samir_bugzilla → nobody
QA Contact: pawyskoczka → bugzilla
Blocks: 226034
I would also like to see a fullscreen mode entry from the command line.
IE has the -k option (kiosk mode).
In my case I want to put the browser in fullscreen mode and use the remote
factility to control the browser and display information. 
Its all hands off to the user.
This can be achieved by using the Autohide extension.
http://www.krickelkrackel.de/autohide/
After installing the extension from the website above:

Start Browser in full screen mode:
    * Use "-fullscreen" as command line option
    * for specific site: -URL "http://www.google.com" -fullscreen
    * Or shutdown while in full screen mode
Duplicate of this bug: 434323
I don't want a builtin function for this, but extensions should be able to do it pretty easily.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
I still think a command-line option would be great. I saves a lot of hassle and is provided with other browsers (-kiosk for chrome for example). I work with two setups where i need to start a lot of firefox instances in full screen. In on setup, we have a X11 window manager installed. That allows me to work-around the missing command-line with wmctrl (a tool that allows you to set the window state of an X11 window). The other does not even run a window manager at all, so my workaround does not work.

I ask you to reconsider this as a feature worth having. It would make my life a lot easier!

On Example:
We use firefox to power a display wall. We use a self-developed software and the SAGE2 software developed at University of Illinois at Chicago’s Electronic Visualization Laboratory (EVL)
and University of Hawai’i at Manoa’s Laboratory for Advanced Visualization and Applications (LAVA).

That allows us to run a ultra-high-resolution displaywall for scientific research on Firefox, i would not have thought this is possible some years ago! Thanks for driving the open web forward so this is even possible today!
I would agree that command-line option makes more sense than use of one or several extensions. With existing workarounds being in essence running FF alongside some macro manager (like xdotool) - e.g. http://ananddrs.com/2014/03/07/firefox-fullscreen/ - it's more or less clear that the extensions route is basically a dead end. 6 years passed, even IE now has the fullscreen/kiosk mode in CLI - perhaps it's time to reconsider?
I have also several use cases for this feature. You cannot always install 3rd-party software on the computer.

In my eyes it belongs to basic features of any GUI application. It should work on stock version of Firefox without playing around.

Also please keep in mind that only Firefox developers could do this feature really reliable (so one can use it for museum kiosks or something), not relying on external extensions.

Also, Google Chrome has it: --start-fullscreen :)
Duplicate of this bug: 1383409
(In reply to Benjamin Smedberg [:bsmedberg] from comment #11)
> I don't want a builtin function for this, but extensions should be able to
> do it pretty easily.

Ended up here when the most recent dupe got filed. Given that add-ons won't be able to do this from 57 onwards, should this be reconsidered?
Flags: needinfo?(benjamin)
I think so because on 57 this feature with addons will be not available :-/
Gijs I don't know... ultimately I don't particularly want to support this feature, primarily because writing tests for it isn't simple. But at the end of the day it's a product decision, feature value versus engineering cost. NI?RT since I think he's the closest product manager to make a decision.
Status: RESOLVED → REOPENED
Component: Cmd-line Features → Startup and Profile System
Flags: needinfo?(benjamin) → needinfo?(rtestard)
Product: Core Graveyard → Toolkit
Resolution: WONTFIX → ---
I'm marking this as enhancement so it gets picked at our next triage session, should be triaged in 2 weeks from now with the rest of the "toolkit" product enhancement backlog.
Severity: normal → enhancement
Flags: needinfo?(rtestard)
One other consideration, which Chrome already provides, is the ability to offset where the browser opens so that a dual-monitor setup (or more) would go fullscreen on different monitors. For example:

firefox.exe --new-window http://localhost/monitor1.html --position=0,0 --start-fullscreen
firefox.exe --new-window http://localhost/monitor2.html --position=1921,0 --start-fullscreen

BTW - spelling fullscreen vs. full screen and the fact that --new-window is not mentioned is how I missed this bug in my searches.

any updates for this?

I'm working on setting up a registration/check-in kiosk for a camp, and was disappointed that I had to run to Chrome to do it because Firefox couldn't do this one thing. Chrome's "-kiosk" command line option is nice for this, launches the app in full-screen with no URL bar and no back buttons or toolbars, just the web page content. Context menu is gone, too, unless the web app provides one. Only way out is Alt+F4 (or Command-Q on a Mac).

From chatter I'm hearing other places, it sounds like bug 1407202 may implement this (not exactly this, but close enough for horseshoes)

OS: Windows 2000 → Unspecified
Hardware: x86 → Unspecified

(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #23)

From chatter I'm hearing other places, it sounds like bug 1407202 may implement this (not exactly this, but close enough for horseshoes)

I can see how bug 1407202 fullscreen concept could be used as a work-around for what we are asking for, but it would require a fair amount of extra work beyond our command-line request. The chatter is definitely not decided on the fullscreen requirement too:

https://bugzilla.mozilla.org/show_bug.cgi?id=1407202#c3

supporting fullscreen apps on desktop seems strange. A sort of windowed mode might be more appropriate.

Most web app manifests specify the standalone display mode, not the
fullscreen display mode. I assume standalone display mode on desktop would
be a window.

Thanks for the update.

Duplicate of this bug: 491588
Assignee: nobody → mozilla
Status: REOPENED → ASSIGNED

Just a quick comment, the patch as I can see involve a preference and not a command line option that is most useful. In this way will be also similar to Chrome as behaviour.

PS: thanks finally a patch after 17 years :-)

I'm only using the pref internally. It will be a command line switch.

Depends on: 1585945
Status: ASSIGNED → RESOLVED
Closed: 11 years agoLast month
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

That seems release notes worthy, Mike could you request an addition to release notes? Thanks https://wiki.mozilla.org/Release_Management/Release_Notes#How_to_nominate_a_bug_for_release_notes_addition.3F

Flags: needinfo?(mozilla)

Note that we've added kiosk mode, not a general-purpose "start in full screen" mode, as kiosk mode does other things, too - and this was a Firefox rather than toolkit change.

Component: Startup and Profile System → General
Product: Toolkit → Firefox
Summary: command line option for full screen mode → command line option for kiosk mode
Target Milestone: mozilla71 → ---
Target Milestone: --- → Firefox 71
See Also: → 1283670

Release Note Request (optional, but appreciated)
[Why is this notable]: 17 year old requested feature :)
[Affects Firefox for Android]: No
[Suggested wording]: Firefox has a new command line parameter, --kiosk, that opens Firefox in fullscreen mode.
[Links (documentation, blog post, etc)]:

relnote-firefox: --- → ?
Flags: needinfo?(mozilla)

Added to nightly notes. We will adjust the relnote flag in this bug when we add the note to beta/release. Thanks.

Depends on: 1590715
QA Whiteboard: [qa-71b-p2]
User Story: (updated)

I have a use case where I would like a kiosk mode with 2 tabs, is it possible to allow tabs to be shown if there are multiple URLS passed through the command line?

No, kiosk mode doesn't show any tabs by design. It's fullscreen firefox.

(In reply to michael.towns from comment #35)

I have a use case where I would like a kiosk mode with 2 tabs, is it possible to allow tabs to be shown if there are multiple URLS passed through the command line?

It's easy to emulate tabs in a kiosk though... you just need a locally-stored HTML page that has your tabs drawn at the top of it and uses IFRAMEs for the real content. Javascript on your "tabs" can swap the IFRAMEs in and out appropriately.

Depends on: 1595511
You need to log in before you can comment on or make changes to this bug.