Multi-monitor: cookie confirmation dialog opens on wrong monitor

VERIFIED DUPLICATE of bug 470356

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 470356
9 years ago
9 years ago

People

(Reporter: challengingusername, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

When using a multi-monitor system and visiting a web site that causes a cookie confirmation dialog to open, the dialog always opens on the 'primary' monitor regardless of where the firefox browser window is located.



Reproducible: Always

Steps to Reproduce:
1. More then one monitor in use.
2. Configuration firefox to ask if cookie should be accepted.
3. Visit web site that uses cookies.
Actual Results:  
Cookie confirmation dialog opens on same monitor (primary/default/number 1) every time.

Expected Results:  
Cookie confirmation dialog should open on the same monitor which the browser is located on (and preferably centered to the browser window, not the desktop window).

Considering switching browsers because this bug is so annoying...

Comment 1

9 years ago
dup of bug 381496?

Comment 2

9 years ago
This is now fixed in Firefox 3.5. If you want to try the beta, you can get it from http://www.mozilla.com/en-US/firefox/all-beta.html.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470356

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.