Error "favoriteFolderMenu is null" opening the Edit menu from Lightning

VERIFIED FIXED in 1.0b1

Status

Calendar
Lightning Only
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Ilja Sekler, Assigned: Fallen)

Tracking

({regression})

Trunk
1.0b1
regression
Dependency tree / graph

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090511 Firefox/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b5pre) Gecko/20090513 Lightning/1.0pre Thunderbird/3.0b3pre

Error: favoriteFolderMenu is null
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 91

in the Error Console opening the Edit menu when in the calendar or in the tasks tab. Unsure whether it is a Thunderbird or a Lightning bug, but it seems that it could be related to the fix for Bug 296655. Doesn't happen with a 2009-05-07-19 (CEST) build.

Reproducible: Always

Steps to Reproduce:
1. Switch to the calendar or to the tasks tab
2. Open the Edit menu

Actual Results:
(Reporter)

Updated

9 years ago
Keywords: regression
Version: unspecified → Trunk
It looks like bug 296655 removed the check to see if the favorites item exists in the menu or not before setting it up.

I'm not sure what's the best to do. Put the check back in - which seems a bit strange, if we've written it in the xul we expect it to be there - or find some other way for lightning to remove/hide our menu items. cc'ing some folks and moving to Lightning for now to get ideas - we can always move it back across if necessary.
Blocks: 296655
Status: UNCONFIRMED → NEW
Component: General → Lightning Only
Ever confirmed: true
Product: Thunderbird → Calendar
QA Contact: general → lightning
(Assignee)

Comment 2

9 years ago
There should be a bunch of changes in bug 456385 that might make this bug obsolete.
Depends on: 456385
Fixed with bug 456385.

Ilja, if you agree, please mark as VERIFIED.
Assignee: nobody → philipp
Status: NEW → RESOLVED
Last Resolved: 9 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Reporter)

Comment 4

9 years ago
VERIFIED FIXED with

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1pre) Gecko/20090620 Lightning/1.0pre Thunderbird/3.0b3pre

SourceStamp=d285993e5dab

Thanks!
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.