Closed Bug 492960 Opened 13 years ago Closed 6 years ago

It flickers when I move a mouse on an disabled context menuitem of pull down Bookmarks menu with Windows Classic Theme

Categories

(Core :: XUL, defect)

1.9.1 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
firefox32 --- affected
firefox33 --- affected
firefox34 --- affected
firefox35 --- affected
firefox36 --- affected
firefox37 --- affected
firefox-esr24 --- affected
firefox-esr31 --- affected

People

(Reporter: alice0775, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, testcase)

Attachments

(2 files, 1 obsolete file)

152.74 KB, image/jpeg
Details
1.61 KB, application/vnd.mozilla.xul+xml
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090513 Firefox/3.5.0 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090513 Minefield/3.6a1pre ID:20090513044918

It flickers when I move a mouse on an disabled context menuitem of pull down Bookmarks menu.

Reproducible: Always

Steps to Reproduce:
1.Start Minefield with new profile
2.Make sure that there is not URl in clipboard.
3.Pull down Bookmarks in the Menumar
4.Right click on the bookmark item.
5.Mouse hover context menuitems.
Actual Results:  
It flickers when I move a mouse on an disabled context menuitem of pull down Bookmarks menu.

Did not emphasize disabled menuitem.


Expected Results:  
Emphasize even disabled menuitem.

It should be behavior same as other context menu (contentarea contextmenu, placesContextmenu of the Sidebar bookmark and the Library).

Works fine:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11pre) Gecko/2009051305 GranParadiso/3.0.11pre ID:2009051305

Broken:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090513 Shiretoko/3.5b5pre ID:20090513045337
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090513 Minefield/3.6a1pre ID:20090513044918



Regression Range:

Works fine:
http://hg.mozilla.org/mozilla-central/rev/a19ab7286802
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081009 Minefield/3.1b2pre

Broken:
http://hg.mozilla.org/mozilla-central/rev/0c41c7f36d2f
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081010 Minefield/3.1b2pre

Push log between the above regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a19ab7286802&tochange=0c41c7f36d2f

Candidate for  regression:  Bug 69710 -  Disabled menu items need more three-dimensional appearance
Blocks: 69710
Keywords: regression
Version: unspecified → 3.5 Branch
Please reproduce with the following condition:
Mouse pointor should hover the disabled manuitem of the Places contextmenu.
And
Mouse pointor should be within the region of pull-down Bookmarks menupopup.
Alice, I cannot see this problem with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090513 Shiretoko/3.5b5pre ID:20090513045337

Which items in the context menu are affected in your builds? There is no flicker when I hover over Paste while the clipboard is empty.
Attached image Screen shot
(In reply to comment #2)
> Alice, I cannot see this problem with Mozilla/5.0 (Windows; U; Windows NT 5.1;
> en-US; rv:1.9.1b5pre) Gecko/20090513 Shiretoko/3.5b5pre ID:20090513045337
> 
> Which items in the context menu are affected in your builds? There is no
> flicker when I hover over Paste while the clipboard is empty.
The issue appear under condition of comment #1.
ie.the context menu, the pull-down menupopup and mouse pointor should be 
overlapped. Mouse hover  "Paste"menuitem  left- right.
Alternative step
1.Pulldown Livebookmark in the Bookmarks toolbar.
2.Right click the left-upper  part of the Livebookmark item
3.Mouse hover "Delete" context menu.
It flickers .
I'm still not able to reproduce it in my WinXP VM. Marco do you see what happens here?
I'm sorry, i'm unable to reproduce. No idea what happens there :(
Alice, and this happens only for the bookmarks menu? No other contextual menus are affected? And also other applications don't show this behavior?
Attached file Test case (obsolete) —
I think not only bookmarks menu.
See attached Test case.

This issue is only Firefox.
It depend on Windows Visual Style.
It happen on Windows Classic theme.
It does not happen on Windows XP Luna theme.
If I put the following css in userChrome.css, the issue was gone.

menuitem[disabled="true"]:-moz-system-metric(windows-classic) {
  text-shadow: none !important;
}
Sorry, but I'm still not able to reproduce this problem. Dao, have you seen this flicker at any time before?
I can reproduce this with XP Classic.
Status: UNCONFIRMED → NEW
Component: Menus → XUL
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
QA Contact: menus → xptoolkit.widgets
Version: 3.5 Branch → 1.9.1 Branch
Using Gecko 1.9.1 I can reproduce the bug, but only a) when using the Classic theme b) when hovering disabled menuitems and c) when the context menu overlaps the bookmarks menu i.e. if you right-click on the right of the bookmark so that the context menu does not overlap then I cannot reproduce the bug.

On trunk, however, the bug seems to be much worse; the context menu still has to overlap the bookmarks menu, but the problem is not limited to disabled menuitems or the Classic theme. In fact, when using the Modern theme, I rarely get overlapped menuitem highlighting at all, let alone flickering.
I wonder if this is the same bug I occasionally run into with both tool tips and status bar messages on link hover, or if I need to open a new bug?  Here is the STR (you may have to make a few attempts -- especially if your computer is fast):

1. If your browser window is maximized, unmaximize it and resize it so it's no more than about 60 % of your screen real estate and fills neither height or width.
2. Make sure your status bar is visible.  If you've hidden it, unhide it.
3. Visit https://addons.mozilla.org/en-US/firefox/addons/versions/13878
4. One the page fully loads, perform the following *very quickly*: double-click the title bar and very quickly move your mouse pointer into the browser's page content area.
5. If you performed Step 4 correctly, your browser window did not completely maximize (animation delay) before your mouse pointer began moving and ended up somewhere over the loaded page.
6. Hover your mouse pointer over the first "Add to Firefox" link.  Notice the link info flashes in the status bar and is not steady.
7. Switch to (or open another tab) then switch back.
8. Now if you hover over the link, it will be steady.
I can not reproduce on latest 1.9.3 trunk any more.
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100610 Minefield/3.7a5pre ID:20100610035756

However, it is still reproduced on 1.9.2 and 1.9.1 branch.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6pre) Gecko/20100609 Namoroka/3.6.6pre ID:20100609042002
Mozilla/5.0 (Windows; U; Windows NT 6.1; ja-JP; rv:1.9.1.11pre) Gecko/20100607 Firefox/3.5.11pre ID:20100607044535
Attached file testcase(4.0b5pre)
Attachment #377563 - Attachment is obsolete: true
Comment on attachment 467166 [details]
testcase(4.0b5pre)

This also happens with Windows 7 Classic style
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100818 Minefield/4.0b5pre ID:20100818112603
Attachment #467166 - Attachment description: testcase() → testcase(4.0b5pre)
Is this bug still relevant?
*This happens on Firefox3.5.17pre and 3.6.14pre.
*This does _not_ happen on Minefield4.0b9pre.
This is almost certainly the same bug I observed on a recent trunk build
while developing the new panel-based Download Manager interface (bug 564934).
When I opened the context menu for download items, flickering occurred when I
moved the cursor over the area of a disabled menu item that overlaps the panel.
I'm also on Windows XP with the classic theme.

For now, I've worked around this bug by making sure that the "menupopup"
element is a child of the "panel" element that contains the download items.
I've been having this problem since 4.0, and it is still present in 5.0. Some quick testing just now reveals that the issue occurs with all menus and context menus; however, I could not reproduce the issue on my primary monitor. In my case, the easiest method of reproduction requires multiple monitors and Windows Classic theme (using Windows 7 OS in this case). I haven't noticed the issue with any other combination (ATI HD series video card, but that is of uncertain relevancy).

1) Open Firefox on a non-primary monitor (window or fullscreen, any size).
2) Open a menu or context menu.
3) Move the cursor from the menu, leaving the menu open, and hover over any hyperlink on the html page.

The menu will disappear from view, but if you have menu shadows enabled, you can still see its shadow. The cursor can then be returned to the menu, but the flickering becomes much worse.

There are other quirks about this bug that produce similar results, but for me, these were the easiest steps to reproduce the bug. This bug is also most likely easier to reproduce with large font sizes.

Additional note: In the case where the menu overlaps a hyperlink, moving the mouse from the menu, to the overlapped hyperlink, and quickly back onto the menu (but still in a location where the cursor would be hovering on the overlapped hyperlink, were the open menu not in the way), the menu will remain transparent. In fact, opening a context menu from a hyperlink and simply leaving the cursor in place of the right-click location, will often cause the menu to immediately become transparent, within a split-second after opening.
Blocks: 825102
No longer blocks: DownloadsPanel
Summary: It flickers when I move a mouse on an disabled context menuitem of pull down Bookmarks menu. → It flickers when I move a mouse on an disabled context menuitem of pull down Bookmarks menu with Windows Classic Theme
See Also: → 1003931
I cannot reproduce the problem on Firefox45.0.1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.