Closed Bug 49331 Opened 20 years ago Closed 14 years ago

Search/Find text "Match upper/lower case" is ambiguous

Categories

(SeaMonkey :: UI Design, defect, P3)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mcoleman2, Assigned: ajschult784)

References

Details

(Whiteboard: patch-maker [good first bug])

Attachments

(1 file, 2 obsolete files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test1 i686; en-US; m17) Gecko/20000807
BuildID:    2000080712

The text for the the Search/Find dialog is ambiguous, to me at least.  "Match
upper/lower case" suggests either that upper must match upper and lower must
match lower (case sensitive) or that characters typed in will match upper or
lower (case insensitive).

Reproducible: Always
Steps to Reproduce:
1.Look
2.
3.

Expected Results:  Maybe just say "case sensitive?"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 7930
In the future, hopefully we will have stuff for matching diacritics and all sorts 
of other minor variants of characters which occur in particular writing systems. 
So whatever we do should be forwards-compatible if possible. I suggest `Exact 
case' (see bug 7930).
Reassigning from bdonohoe to hangas
Assignee: bdonohoe → hangas
No longer blocks: 7930
Depends on: 7930
Status: NEW → ASSIGNED
From bug 66696:

"match upper/lower case" is ambiguous because it suggests that _either_ could be
matched. a much more concise way of saying "case sensitive" would be "match case".
*** Bug 66696 has been marked as a duplicate of this bug. ***
Chaning the qa contact on these bugs to me. MPT will be moving to the 
owner of this component shortly. I would like to thank him for all his hard 
work as he moves roles in mozilla.org...Yada, Yada, Yada...
QA Contact: mpt → zach
updating to new owner. sorry for the spam.
Assignee: hangas → mpt
Status: ASSIGNED → NEW
OS: Linux → All
Hardware: PC → All
Whiteboard: patch-maker
Attached patch Chang text to "Match Exact Case" (obsolete) — Splinter Review
Changes text to "Match Exact Case" for both the find and find&replace dialogs.
Only works for en-US. I think the rest is up to the localization people.
Ahh, I didn't see what you meant in the last post. This patch changes the text
for all of those locations, except for the non-en-US ones. Sorry `bout that.
Attachment #59130 - Attachment is obsolete: true
I like it! Perhaps need review?
BTW what about the dependency?
I think that the dependency is sora unrelated, that this will fix this current
dialog, and if they redo the dialog, they can still use this patch, I guess, I
only changed DTD's and help files.

If someone special could check this out i'd be very nice. There's not alot to
review, no code, it's mostly just a matter of if it should be changed or not.
.
Assignee: mpt → blaker
Component: User Interface Design → XP Apps: GUI Features
QA Contact: zach → paw
This bug has existed for nearly three years now, with a year-old patch that
hasn't been accepted, and this still trips me up whenever I need to search for
something. What's the status on this thing?
Product: Core → Mozilla Application Suite
(In reply to comment #13)

incredible. it seems so trivial.
(In reply to comment #14)
> (In reply to comment #13)
> 
> incredible. it seems so trivial.

I just got confused by this too, and wanted to file a bug report, but found out the deficiency is already known since 5 years. FC4 Mozilla 1.7.10 still shows Match upper/lower case, which I interpreted as upper OR lower case. A bit of a sad story.
does a language issue need to be addressed?
line numbers for patch attachment 59217 [details] [diff] [review] have changed except for finddialog.dtd
patch author Colin is not reachable
Assignee: bross2 → guifeatures
Severity: normal → minor
No longer depends on: 7930
QA Contact: pawyskoczka
Whiteboard: patch-maker → patch-maker [good first bug]
Attached patch updated patchSplinter Review
toolkit find dialog just says "Match case"
Attachment #59217 - Attachment is obsolete: true
Attachment #240821 - Flags: superreview?(neil)
Attachment #240821 - Flags: review?(neil)
Attachment #240821 - Flags: superreview?(neil)
Attachment #240821 - Flags: superreview+
Attachment #240821 - Flags: review?(neil)
Attachment #240821 - Flags: review+
Assignee: guifeatures → ajschult
FIXED
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.