Closed Bug 493355 Opened 11 years ago Closed 9 years ago

browser_library_left_pane_commands.js times out intermittently

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ehsan, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [needs investigation])

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1242438902.1242445790.8469.gz
WINNT 5.2 mozilla-central unit test on 2009/05/15 18:55:02

Starting test browser_library_left_pane_commands.js
TEST: Bug 489351 - Date containers under History in Library cannot be deleted/cut
TEST: Bug 490156 - Can't delete smart bookmark containers

command timed out: 1200 seconds without output
program finished with exit code 1
elapsedTime=1237.250000
TinderboxPrint: mochitest-browser-chrome<br/><em class="testfail">T-FAIL</em>
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output
TinderboxPrint: mochitest-browser-chrome<br/><em class="testfail">timeout</em>
=== Output ended ===
======== BuildStep ended ========
Whiteboard: [random-orange]
Whiteboard: [random-orange] → [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1242746909.1242756310.23780.gz#err0
Linux mozilla-central unit test on 2009/05/19 08:28:29

As in comment 0, this was a timeout right after this line:
> TEST: Bug 490156 - Can't delete smart bookmark containers
OS: Windows Server 2003 → All
Hardware: x86 → All
The next cycle on the tinderbox from comment 1 had this failure, too (a bit suspicious... possibly these two logs are actually indicative of an issue, rather than being sporadic -- noting here anyway, though)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1242748693.1242756519.24449.gz
Linux mozilla-central unit test on 2009/05/19 08:58:13
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1242757293.1242763892.11893.gz#err0
Linux mozilla-central unit test on 2009/05/19 11:21:33  


Looks like this is happening a *lot* right now on the Linux box.
This has timed out on every single cycle today since comment 1.  This seems quite different from the low-frequency intermittent failure that this original bug was filed about, so I've filed Bug 493892 on today's consistent timeout.
See also Bug 494494, which is also a sporadic timeout after the same "Can't delete smart bookmark containers" message, but in a different testcase (browser_bookmarksProperties.js)
(In reply to comment #6)
> *** Bug 494494 has been marked as a duplicate of this bug. ***

That bug reported it against FF 3.5 too.
taking for investigation.
Assignee: nobody → mak77
actually, i have a doubt, there's no indication that the intermittent test is browser_library_left_pane_commands.js, could be that test is the last one that dumps something before the failure, but the failing test is one of the next ones tat does not dump anything. would be cool if the testsuite would dump start and end of each test it executes.
(In reply to comment #9)
> actually, i have a doubt, there's no indication that the intermittent test is
> browser_library_left_pane_commands.js, could be that test is the last one that
> dumps something before the failure, but the failing test is one of the next
> ones tat does not dump anything. would be cool if the testsuite would dump
> start and end of each test it executes.
Want to file a bug on that?  That seems like it'd be really really useful.
(In reply to comment #10)
> Want to file a bug on that?  That seems like it'd be really really useful.

yeah, and it's not hard to implement, filed bug 495091.
I need better logging to investigate this, bug 492467 and bug 481406 should be fixed soon and should provide what is needed.
Depends on: 492467
actually i did never see any new failure, so could be the above timeout was coming from some other test, if anyone did, please report.

unassigning till then.
Assignee: mak77 → nobody
i'm resolving since there is not proof the timeout is due to this test. Feel free to reopen if you see a related failure in future.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Timeout certainly in this test:
http://tinderbox.mozilla.org/showlog.cgi?log=Places/1266436117.1266437979.30037.gz&fulltext=1#err0
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [orange] → [orange][needs investigation]
doesn't happen from a long time
Status: REOPENED → RESOLVED
Closed: 11 years ago9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange][needs investigation] → [needs investigation]
You need to log in before you can comment on or make changes to this bug.