Closed Bug 493560 Opened 11 years ago Closed 11 years ago

Upgrade to SQLite 3.6.14.2

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: sdwilsh, Assigned: sdwilsh)

References

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #489442 +++

We'll be taking a special branch containing two fixes - one we need, and one recommended by the SQLite folks.

Fixes this will contain on top of 3.6.14:
http://www.sqlite.org/cvstrac/tktview?tn=3841 (we need this one for places)
http://www.sqlite.org/cvstrac/tktview?tn=3844 (suggested that we take this)
Attached patch v1.0 (obsolete) — Splinter Review
I've pushed this to the try server to verify that there are no performance regressions or unit test regressions.
Attachment #378071 - Flags: review?(bugmail)
Whiteboard: [needs review asuth]
Are the SQLite folks going to officially release 3.6.14.1?  It is not public/visible on their site currently.  If not, how are distributions that build using system SQLite supposed to meet the configure requirement?
It's still in QA on their end - we are working in parallel (and I obviously won't land this until they give me the all clear).
Attachment #378071 - Flags: review?(bugmail) → review+
Whiteboard: [needs review asuth] → [can land when all clear]
Looks OK on the try server (one known random orange did happen on windows, so I'm running it again).

Still waiting for the SQLite folks to sign off.
Got the all clear last night, and it's been released on the SQLite website.
Whiteboard: [can land when all clear] → [can land]
http://hg.mozilla.org/mozilla-central/rev/dd3d70e5849e
http://hg.mozilla.org/mozilla-central/rev/4480c18255f2
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [can land]
Target Milestone: --- → mozilla1.9.2a1
Attachment #378071 - Flags: approval1.9.1?
Comment on attachment 378071 [details] [diff] [review]
v1.0

I'd really like to get this on 1.9.1 so that we can bumb the min-version of SQLite so folks don't try to ship with a known-bad system SQLite.  It'll also fix the two bugs this blocks on branch, as well as get us some minor performance and stability wins (we were previously on 3.6.10).
Needs more baking before we'd take it on 191
(In reply to comment #8)
> Needs more baking before we'd take it on 191
Right, I don't expect approval today.
This was backed out with changeset: 
http://hg.mozilla.org/mozilla-central/rev/cc61db43d445

Shouldn't this be re-opened ?
(In reply to comment #10)
> Shouldn't this be re-opened ?
Yes, this was backed out because it was thought to have caused orange on the tree.  It turns out it wasn't the culprit.  I was going to land this this morning, but now the tree is closed and only accepting blockers, so it looks like this won't make 1.9.1 :(
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 378071 [details] [diff] [review]
v1.0

Needs to bake on trunk before we would consider it.
Attachment #378071 - Flags: approval1.9.1?
Comment on attachment 378071 [details] [diff] [review]
v1.0

So, this can't land on 1.9.1 because it hasn't landed on mozilla-central and baked.  I can't land it on mozilla-central unless I get approval for 1.9.1.  I'm requesting approval in order to get it on mozilla-central, where we can then evaluate if we want it for 1.9.1.
Blocks: 489589
No longer blocks: 489589
Blocks: 489589
Shawn, can you push the new SQLite into mozilla-central without approval for 1.9.1?

This upgrade fixes bug 489589 anyway. If new other bugs will be introduced by upgrading, I will try fix it.
(In reply to comment #14)
> Shawn, can you push the new SQLite into mozilla-central without approval for
> 1.9.1?
> 
> This upgrade fixes bug 489589 anyway. If new other bugs will be introduced by
> upgrading, I will try fix it.
Not per tree rules right now, unless those have changed without my knowledge.
SQLite just released a new version for a bug fix that we are highly unlikely to hit.  This is version 3.6.14.2, so I'm updating the patches for this bug.  I pushed this to the try server to make sure all is good (things look good locally).

The change in question is http://www.sqlite.org/cvstrac/tktview?tn=3879
Status: REOPENED → NEW
Summary: Upgrade to SQLite 3.6.14.1 → Upgrade to SQLite 3.6.14.2
Attached patch v2.0Splinter Review
This shouldn't need a new review.
Attachment #378071 - Attachment is obsolete: true
Attachment #378071 - Flags: approval1.9.1?
Whiteboard: [baking on tryserver]
I confirmed version 3.6.14.2 fixed bug 489589.
I am sufficient convinced that this isn't going to cause any problems based on a few try server runs.
Status: NEW → ASSIGNED
Whiteboard: [baking on tryserver]
Whiteboard: [can land]
http://hg.mozilla.org/mozilla-central/rev/77f92242f164
http://hg.mozilla.org/mozilla-central/rev/11e357b100c0
Status: ASSIGNED → RESOLVED
Closed: 11 years ago11 years ago
Flags: wanted1.9.1.x?
Resolution: --- → FIXED
Whiteboard: [can land]
Taking this on 1.9.1 would fix the #20 topcrash (bug 503770).
Bug 508104 is the one Shawn is trying to land on 1.9.1.
Flags: wanted1.9.1.x?
In fact, I'd rather take bug 508104 because we've at least shipped an alpha with it.  We didn't ship anything but nightlies with this release.
You need to log in before you can comment on or make changes to this bug.