Can't remove some files from CVS repository

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: davidwboswell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I'm removing files in the /start/ directory, but can't remove anything in:

/html/start/1.4/Troubleshooting/
/html/start/1.5/Troubleshooting/

My guess is that there's something going on with the capitalization.  For instance, in my local copy of the files the directory is capitalized, but through bonsai, MXR and the web site the directory is not capitalized.  Compare:

http://bonsai-www.mozilla.org/cvslog.cgi?file=mozilla-org/html/start/1.4/troubleshooting/index.html&rev=&root=/www/

http://bonsai-www.mozilla.org/cvslog.cgi?file=mozilla-org/html/start/1.4/Troubleshooting/index.html&rev=&root=/www/

And this is the error I'm getting when I tried to remove the files:

davids-macbook-pro:Troubleshooting david$ rm index.html 
davids-macbook-pro:Troubleshooting david$ cvs rm index.html
cvs remove: scheduling `index.html' for removal
cvs remove: use 'cvs commit' to remove this file permanently
davids-macbook-pro:Troubleshooting david$ cvs ci -m "Archiving old Mozilla Suite start content" index.html
cvs commit: Up-to-date check failed for `index.html'
cvs [commit aborted]: correct above errors first!

I've done a CVS update several times and that isn't fixing this.
(Reporter)

Comment 1

9 years ago
I ran into another problem with removing files from CVS -- this time from the mailnews directory.  I could cvs rm them, but got an error on commit.  I'm not sure if this is the same sort of problem as mentioned above or not.

cvs commit: file `review-mail.html' had a conflict and has not been modified
cvs commit: file `review.html' had a conflict and has not been modified
Summary: Can't remove files in Troubleshooting directories → Can't remove some files from CVS repository
(Reporter)

Comment 2

9 years ago
Raising priority.
Priority: -- → P2
(Reporter)

Updated

9 years ago
Blocks: 484018, 493646
(Reporter)

Comment 3

9 years ago
I was able to remove these files from Subversion and I don't imagine there's any need to worry about the files in CVS at this point.  Closing as fixed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.