Mozilla doesn't honor focus-follows-mouse

VERIFIED DUPLICATE of bug 9701

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 9701
18 years ago
13 years ago

People

(Reporter: David Muir Sharnoff, Assigned: asa)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD 4.0-STABLE i386; en-US; m17)
Gecko/20000815
BuildID:    00000000000000

My window manager is set to focus-follows-mouse.  I often find
that the keyboard shortcuts for scrolling don't work until
I've clicked in the window.

No, this isn't frames related...  


Reproducible: Sometimes
Steps to Reproduce:
1. Set your window manager to focus-follows-mouse
2. Open some page
3. Open a link in a new window.
4. Move the mouse back over the first window.
5. Use PageUp/PageDown to scroll.

Actual Results:  Sometimes it scrolls, sometimes it doesn't.					

Expected Results:  It should scroll consistently.

Comment 1

18 years ago
dup of bug 42004? ("page up/down keys don't work after using right-click menu
back/forward")
If so, clicking content with mouse seems to enable the keybinding again.

Comment 2

18 years ago
Confirming on 2000081808/Linux. When the browser is not in focus and focus is
switched to the browser by moving the mouse pointer over it, the arrow keys
can't always be used to scroll until the browser is clicked on.
Don't know about he dupe...

Comment 3

18 years ago
it's a dup of 42004 or bug 9701 ""nsWebShell Key events not working until focus
set in window."
(42004 seems to be a dup of 9701)
(Assignee)

Comment 4

18 years ago
resolving as a dupe of bug 9701

*** This bug has been marked as a duplicate of 9701 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.