Developer Adding Tags: UI

VERIFIED FIXED in 5.0.7

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: Mike Lee, Assigned: Andrew Wooldridge)

Tracking

unspecified
5.0.7

Details

(Whiteboard: [webmocha])

(Reporter)

Description

9 years ago
As indicated on the Tagging Spec
(http://docs.google.com/Doc?docid=dds6vwb4_1dxwx5vg3&hl=en)

1.2 - Developer Tags
On the add-on edit screen developers can specify one or more tags (up to a
total of 80) which are space delimited.  These tags will appear in the order
that they were entered on the final screen.  These tags appear on listing pages
as well as in search results as part of the add-on metadata.

This bug involves the HTML/CSS/jQuery portion of this task.
(Reporter)

Comment 1

9 years ago
Hi Nick,

As visual designs are completed for this UI flow (or if you're able to articulate what the flow should do & look like), please add them to this bug. Thanks.
(Reporter)

Updated

9 years ago
Severity: enhancement → normal
Neil,

Can you attach a wireframe for this?

Updated

9 years ago
Whiteboard: [webmocha]

Comment 3

9 years ago
How do I see what the existing "add-on edit screen" looks like? Is there a mock or URL I can see?
(Assignee)

Comment 4

9 years ago
Hi, I need visual designs for this asap :)
(Reporter)

Comment 5

9 years ago
Is this the wireframe for adding tags?
https://bug488517.bugzilla.mozilla.org/attachment.cgi?id=380325

Andrew: visual designs don't exists for this interaction, just these
wireframes. You can use the existing elements from the other visual designs to
build this feature.
(Assignee)

Comment 6

9 years ago
The tagging spec above seems to suggest a single field that the developer uses to add a bunch of tags at once? Or is it now more like the interaction you mention in comment#5

Comment 7

9 years ago
Hi Andrew - it's meant to be a single text field ala Delicious or Flickr's tag entry system.

Feel free to email me directly if you have any questions whatsoever about design, flow, UX, etc.
(Assignee)

Comment 8

9 years ago
Blocked on this until Patrick creates the page.
(Assignee)

Comment 9

9 years ago
user can add tags via js or non js now.
r28193
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

9 years ago
argh, wrong bug...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

9 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 11

9 years ago
This bug is almost done - just need Patrick to add the tags.js to this page to get the ajax functionality.
(Assignee)

Comment 12

9 years ago
Confirmed that css an js are same as user tags page. Fixed a small issue and updated the revision

r28286
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
verified  fixed
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.