Install to location w/o write perms creates multiple unclear error msgs

VERIFIED DUPLICATE of bug 46558

Status

SeaMonkey
Installer
P3
normal
VERIFIED DUPLICATE of bug 46558
18 years ago
13 years ago

People

(Reporter: David Epstein, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux only. Mozilla build 2000-08-18-08-M18.
1. Download Linux install stub. gzip and tar extract.
2. Run the installer.
3. Open the directory selector.
4. Select directory location /usr/local.
5. Click OK.
Result: While installing, several small error message windows pop up. Each one 
has "Error -421; A .xpi failed to install."
Expected: Only ONE such message window should appear. And the message should be 
more user friendly, indicating that user doesn't have permissions to install to 
that location.

Updated

18 years ago
QA Contact: gemal → gbush
(Assignee)

Comment 1

18 years ago
Linux == sgehani.
Assignee: ssu → sgehani
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
It'd be nice to do a permissions sanity check before downloading anything, at 
least for the main directory users pick in the wizard. Not sure we could do 
much about any directories not under that sub-tree, but most of our stuff 
installs into the same place.
(Assignee)

Comment 3

18 years ago
Yes, this is one I'd really like to fix if I get time.
(Assignee)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 46558 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
vfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.