Stat for permissions to target dir before continuing from setup type dlg

VERIFIED FIXED in mozilla0.9

Status

P3
normal
VERIFIED FIXED
19 years ago
15 years ago

People

(Reporter: pawyskoczka, Assigned: samir_bugzilla)

Tracking

Trunk
mozilla0.9
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xpibug] Fix in hand)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Build 2000072609 on Linux only

Steps:
1. Download Linux installer from sweetlou
2. Unzip and untar the file
3. Run the installer and accept all the defaults
4. Install to /usr/local/netscape without changing the permissions on the 
folder.
5. The install runs and downloads the xpi files but does not install.


No error message is displayed.  
Change the permission and the browser is installed.
(Assignee)

Comment 1

19 years ago
Changed summary to reflect bug.  This will be easily encountered by the target 
group using a GUI installer on Linux.  Hence, nominating for nsbeta3.

Steve,
Could you document in the README's linux installer instructions that users must 
ensure that they have write permission for the target installation directory 
(default is /usr/local/bin but is changable through the installer's file 
selection dialog) before trying to install?  Thanks.
Status: NEW → ASSIGNED
Keywords: nsbeta3
Summary: Linux installer failed to complete installation → Stat for permissions to target dir before continuing from setup type dlg
(Assignee)

Comment 2

19 years ago
Reassigning to moi.
Assignee: ssu → sgehani
Status: ASSIGNED → NEW
Target Milestone: --- → M18
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 3

19 years ago
Release note for Beta2.  Added keyword
Keywords: relnote
(Assignee)

Updated

19 years ago
Whiteboard: [nsbeta3-]

Comment 4

19 years ago
I think we should do more than just document this in a README file.  The
installer should check the directory right after it is selected before anything
else happens.  If it is not writeable a Permission Denied message should be
displayed and the installer should exit.
(Assignee)

Comment 5

19 years ago
Actually David, I think we should ask the user to select another directory 
instead of exiting.  Agree?

Comment 6

19 years ago
Samir, yes I think that would be more preferable to exiting.

Updated

19 years ago
Keywords: helpwanted
Bug 55754 is similar, but a crash.
Whiteboard: [nsbeta3-] → [nsbeta3-] relnote-user
(Assignee)

Updated

19 years ago
Priority: P3 → P1
(Assignee)

Comment 8

19 years ago
*** Bug 49482 has been marked as a duplicate of this bug. ***
Unsetting missed milestones to aid triage queries.
Target Milestone: M18 → ---
Isn't this one fixed? Last time I tried it I got a dialog box saying I didn't
have write permissions to /usr/local/mozilla
Keywords: nsbeta1
Whiteboard: [nsbeta3-] relnote-user → [xpibug][nsbeta3-] relnote-user
Moz 0.9 tasks
Target Milestone: --- → mozilla0.9
(Assignee)

Updated

18 years ago
Priority: P1 → P3

Updated

18 years ago
Keywords: helpwanted, nsbeta1, nsbeta3, relnote → nsbeta1+
(Assignee)

Comment 12

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

18 years ago
Oops, marked wrong bug fixed.  (Bug 54668 was fixed.)  Reopening.  Sorry for the
spam.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 15

18 years ago
ssu, please review.
mscott, please super review.

Thanks.
(Assignee)

Updated

18 years ago
Whiteboard: [xpibug][nsbeta3-] relnote-user → [xpibug] Fix in hand
(Assignee)

Comment 16

18 years ago

Comment 17

18 years ago
r=ssu d00d'ms

Comment 18

18 years ago
sr=alecf
(Assignee)

Comment 19

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 20

18 years ago
Samir,

when I choose default (/usr/local/netscape) for which I do not have permission
to install....I am getting two messages...1l- directory does not exist -create
it?  and then 2. error -624  'can't make directory...choose another'  
I question because I was expecting error -626 per patch  vs the -624
Expected?
(Assignee)

Comment 21

18 years ago
E_MKDIR_FAIL == -624 which is correct.  If the directory already existed and the
user didn't have rwx perms and tried to proceed then you would see E_NO_PERMS ==
-626.  

Comment 22

18 years ago
verify 2001040305
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.