Closed Bug 494925 Opened 12 years ago Closed 12 years ago

incorporate removal of keyhole etch from Firefox theme for Mac OS X

Categories

(Mozilla Labs Graveyard :: Personas Plus, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: myk, Assigned: myk)

References

Details

Attachments

(2 files)

Firefox for Mac OS X has removed the "etch" around the keyhole per bug 462644.  Personas should incorporate this change as well, so the keyhole looks the same with a persona selected as it does with the default Firefox theme.
No longer depends on: 462644
FWIW, I think you can make this change so that it removes the "etch" from Firefox 3.0.x and 3.5.x. I don't think it was adding a lot to Personas :)
Depends on: 462644
Toolbar.png updated for all OSes would do the trick, but there will need to be some CSS shifting edits since the back/forward button footprint in now smaller. 

We don't use our own Personas-specific PNGs for Windows/Linux, so the fix there should be CSS only - using the new toolbar.png within 3.5.  

As for OSX, I'll nab the latest toolbar.png and do our Personas-specific transparency updating.
Attachment #379754 - Attachment description: Revised OSX Toolbar.png (3.5 compatibility) → Revised OSX Toolbar-rtl.png (3.5 compatibility)
Blocks: 494976
(In reply to comment #1)
> FWIW, I think you can make this change so that it removes the "etch" from
> Firefox 3.0.x and 3.5.x. I don't think it was adding a lot to Personas :)

Yeah, that's a good idea, but it's also cumbersome to do, since as Sean points out it requires us to include all the -moz-image-region rules for each individual button, whereas currently we only override list-style-image and reuse the core Firefox -moz-image-region rules to pick out the individual buttons in the Personas Toolbar.png image.

So I think I'm going to let this sleeping dog lie.

Fixed by changeset http://hg.mozilla.org/labs/personas/rev/0a83a7839602.  I filed bug 494976 on releasing an updated version of the extension that includes this fix.
Assignee: cbeard → myk
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Note: I've pushed a development build including this change so y'all can confirm that it does indeed resolve the problem:

https://people.mozilla.com/~cbeard/personas/dist/personas-dev.xpi

Also, note that previously we didn't ship an RTL image for these buttons, so this change also fixes the appearance of the buttons for RTL locales.
Duplicate of this bug: 497239
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.