Open Bug 495230 Opened 12 years ago Updated 4 years ago

Error: focusedWindow.getSelection() is null in this case when iframe gets display: none

Categories

(Toolkit :: Find Toolbar, defect, P5)

x86
Windows XP
defect

Tracking

()

REOPENED

People

(Reporter: martijn.martijn, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Attached file testcase
See testcase, I'm getting this error when pressing the ctl-f key with it:
Error: focusedWindow.getSelection() is null
Source File: chrome://global/content/bindings/findbar.xml
Line: 1631

I guess it shouldn't be possible for document.commandDispatcher.focusedWindow to be a display: none iframe, but since that appears to be possible, the findbar code should cope with it.
This bug affects also contenteditable frame, verified with attached TC.
See also CKEditor bug:
http://dev.ckeditor.com/ticket/6577
Duplicate of this bug: 827585
Depends on: 827585
I think this is related to bug 585229 but I'm not sure if it's a dup or not. Boris, can we close either as a dup of the other?
Flags: needinfo?(bzbarsky)
This is related, but not a duplicate.  Specifically, this bug is for how our UI handles the situation caused by bug 585229.
Flags: needinfo?(bzbarsky)
Priority: -- → P5
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.