Last Comment Bug 495241 - [Feature] Multiple Recipients per line in compose window
: [Feature] Multiple Recipients per line in compose window
Status: RESOLVED DUPLICATE of bug 440377
:
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: unspecified
: All All
-- enhancement with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 08:11 PDT by Vinay Y S
Modified: 2011-09-29 07:27 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Vinay Y S 2009-05-28 08:11:42 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/528.18.1 (KHTML, like Gecko) Version/4.0 Safari/528.17
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

Allow for multiple recipient addresses separated by comma or semi-colon in a single address field of compose window. This will make better use of the horizontal screen space and avoid scroll-bar for that section of the screen for most cases. This will greatly improve usability as one can review all the recipients easily without having to do any mouse action like scroll up/down. Also, this is very common UI design in most native and web based e-mail clients which would be familiar to the user.

Reproducible: Always




If there is a good reason for having one address per line field in the compose window, please mention it. 

Unless there is a strong usability/ui-desgin rationale for the current behavior, please consider changing it and implementing this feature request.
Comment 1 User image WADA:World Anti-bad-Duping Agency 2009-05-29 04:37:31 PDT
> Allow for multiple recipient addresses separated by comma or semi-colon in a
> single address field of compose window.

AFAIK, UI doesn't reject "comma separated mail addresses" like To: or CC: header. You can type or paste "comma separated mail addresses" in To:, CC:, BCC: field during mail composition, although there is restriction / limitation / special behaviour in special case such as '"', '\"', "\<", "\>", "\," at UI, and although "one row for an mail address" is displayed by UI as you say once mail data is saved and re-edited(reply, edit draft, etc.).
So "comma & composition" part can be said as INVALID.
"semicolon" part is probably WONTFIX. (AFAIR, some MS's mailer users requested it, bu no one tried to implement it. And, ";" is key delimiter character of group-address.)
Comment 2 User image Vinay Y S 2009-05-30 06:36:31 PDT
(In reply to comment #1)
> AFAIK, UI doesn't reject "comma separated mail addresses" like To: or CC:
> header. You can type or paste "comma separated mail addresses" in To:, CC:,
> BCC: field during mail composition, although there is restriction / limitation
> / special behaviour in special case such as '"', '\"', "\<", "\>", "\," at UI,
> and although "one row for an mail address" is displayed by UI as you say once
> mail data is saved and re-edited(reply, edit draft, etc.).
> So "comma & composition" part can be said as INVALID.
It's not only reply, edit, draft etc, even though it allows you enter comma separated addresses in one line, the moment you hit tab and/or move to main edit area, the e-mail addresses move to one-address-per-line format bringing in the scroll bar. That is the main issue, ie., having to scroll to review the recipients of the e-mail while composing, replying etc. I hope the intent of this feature request is clear.

> "semicolon" part is probably WONTFIX. (AFAIR, some MS's mailer users requested
> it, bu no one tried to implement it. And, ";" is key delimiter character of
> group-address.)
I'm not very particular of semi-colon vs comma. If either one is supported it's enough; if both are supported it's great.
Comment 3 User image Magnus Melin 2009-05-31 10:22:18 PDT
xref/dupe bug 392932.
Comment 4 User image Jonathan Thomas 2010-02-05 22:59:19 PST
It's nice to be able to add multiple email addresses on a single line, but Thunderbird stops auto-completing the email addresses after the first comma.  Also, there is no easy way (that I have found) to copy a partial list of recipients from an email into a new compose window.
Comment 5 User image Steve McMillen 2010-11-15 22:10:07 PST
I'd very much like to see this.  I find myself scrolling up and down to see all recipients and double check if I've got all the to: and cc: correct. 

Overall, the address region takes too much vertical space that would be much better left for the message body.  I think the "From" dropdown could be reduce to 1/2 the width and add some other UI control next to it.  

There should just be a To, CC and BCC line and ideally the bcc line is hidden normally since many don't use it.
Comment 6 User image [:Aureliano Buendía] 2011-09-29 07:27:37 PDT

*** This bug has been marked as a duplicate of bug 440377 ***

Note You need to log in before you can comment on or make changes to this bug.