Video on http://www.youtube.com/html5 doesn't play

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: lars.sonchocky-helldorf, Unassigned)

Tracking

1.9.1 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PowerPC Mac OS X 10_4_11; en-US) AppleWebKit/528.16 (KHTML, like Gecko, Safari/528.16) OmniWeb/v622.8.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2a1pre) Gecko/20090528 Minefield/3.6a1pre

http://www.youtube.com/html5 is a test implementation of youtube using just HTML5 features (hence the URL) and no flash. So far the video on that page doesn't play and some pictures and controls have blue borders that shouldn't be there

Reproducible: Always

Steps to Reproduce:
1. Visit above page
Actual Results:  
Video at http://www.youtube.com/html5 doesn't play

Expected Results:  
Video at http://www.youtube.com/html5 plays

Comment 1

10 years ago
The video is encoded in h264 http://en.wikipedia.org/wiki/H.264 Firefox only plays ogg/theora <video>. H.264 is encumbered with patents, the source is not available to be integrated with the source code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> (...) the source is not
> available to be integrated with the source code.

ffplay from FFmpeg project (http://ffmpeg.org/) plays it fine. FFmpeg is open source, so source code _is_ available (licensing/patent issues aside...).
(In reply to comment #2)
> (In reply to comment #1)
> > (...) the source is not
> > available to be integrated with the source code.
> 
> ffplay from FFmpeg project (http://ffmpeg.org/) plays it fine. (...).

(By "it" I mean the downloaded file http://www.youtube.com/demo/google_main.mp4?2 which is embedded in <video> on the site mentioned in comment 0. Sorry about confusion and bugspam.)

Comment 4

10 years ago
Incorrect read http://ffmpeg.org/legal.html

Q: Since FFmpeg is licensed under the LGPL, is it perfectly alright to incorporate the whole FFmpeg core into my own commercial product?
A: You might have a problem here. Sure, the LGPL allows you to incorporate the code. However, there have been cases where companies have used FFmpeg in their projects, usually for such capabilities as superior MPEG-4 decoding. These companies found out that once you start trying to make money from certain technologies, the alleged owners of the technologies will come after their protection money. Most notably, MPEG-LA (licensing authority) is vigilant and diligent about collecting for MPEG-related technologies.

Distributing ffmpeg to 100+ million users across the globe would easily incur the same legal threats that other companies have faced. 

For an example of the sorts of fees that Mozilla would be required to pay see http://www.mpegla.com/news/n_02-07-15_m4v.html

Comment 5

10 years ago
Sorry about bugspam, but I think this is at least partly relevant.

This bug could be considered as fixed once the "native back-ends" are completed. (See bug 422540, bug 435298 and bug 435339)

Updated

10 years ago
Duplicate of this bug: 501395

Comment 7

10 years ago
In the meantime should we add a 'broken movie' icon, in the same way as when an image file can't be loaded?

Updated

10 years ago
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → 1.9.1 Branch
(In reply to comment #7)
> In the meantime should we add a 'broken movie' icon, in the same way as when an
> image file can't be loaded?

Firefox's native controls will show this (right click on the video element and select "show controls").  The Youtube demo uses custom controls that don't indicate an error.

Comment 9

9 years ago
From the Youtube page,. Notice firefox is NOT listed:

Supported Browsers

Right now we support browsers that support both the <video> tag in HTML5 and the h.264 video codec. These include:

    * Google Chrome
    * Apple Safari (version 4+)
    * Microsoft Internet Explorer with Chrome Frame installed (Get Chrome Frame)

Updated

9 years ago
Duplicate of this bug: 541173

Comment 11

9 years ago
Is there any way an extension or plug-in can handle the video tag in place of Firefox?

Comment 12

9 years ago
Surely the whole point of the video tag was about distributing the load on the process? Thus surely the video tag should be using another process by default, which leads me to question why I can't edit my config and get Media Player Classic Home Cinema/Windows Media Player/Quicktime/etc to handle video?
You need to log in before you can comment on or make changes to this bug.