Closed Bug 496006 Opened 11 years ago Closed 11 years ago

Empty inline moves in this case with direction: rtl

Categories

(Core :: Layout: Text and Fonts, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: smontagu)

References

Details

(Keywords: regression, testcase, verified1.9.1.1)

Attachments

(2 files)

Attached file testcase
See testcase, the black vertical line on the right is moving after 500ms. That should not be happening. I guess the end result is the correct result.

This regressed between 2009-05-09 and 2009-05-11:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2009-05-09+04%3A00%3A00&enddate=2009-05-11+09%3A00%3A00
I think a regression from bug 492231.
I am seeing a different regression range: 2009-04-18 - 2009-04-19: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b618ca270e9b&tochange=907f2f562f44, which looks like bug 332655 (again, <sigh>)
Assignee: nobody → smontagu
Blocks: 332655
No longer blocks: 492231
Attached patch PatchSplinter Review
I was unsure when working on bug 332655 whether this block needed to be inside or outside the |if (contentOffset + fragmentLength == contentTextLength)| but couldn't find a case where it made a difference.
Attachment #382049 - Flags: superreview?(roc)
Attachment #382049 - Flags: review?(roc)
Comment on attachment 382049 [details] [diff] [review]
Patch

+setTimeout(doe, 500);

Why do we need this?
Attachment #382049 - Flags: superreview?(roc)
Attachment #382049 - Flags: superreview+
Attachment #382049 - Flags: review?(roc)
Attachment #382049 - Flags: review+
(In reply to comment #3)
> +setTimeout(doe, 500);
> 
> Why do we need this?

I tried replacing it by an onload and the bug didn't reproduce.
http://hg.mozilla.org/mozilla-central/rev/4f11e242a00e
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Attachment #382049 - Flags: approval1.9.1?
Comment on attachment 382049 [details] [diff] [review]
Patch

Asking approval1.9.1 for this simple regression fix.
Fixed on 1.9.1.1 by the checkin for bug 499538 in http://hg.mozilla.org/releases/mozilla-1.9.1/rev/a1877fc03af3
Keywords: fixed1.9.1.1
Attachment #382049 - Flags: approval1.9.1?
Verified fix on Mozilla/5.0 (Windows; U; Windows NT 5.1; he; rv:1.9.1.1pre) Gecko/20090714 Shiretoko/3.5.1pre
and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090714 Minefield/3.6a1pre
and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1pre) Gecko/20090714 Shiretoko/3.5.1pre Ubiquity/0.1.5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.