If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Visit date in history view mode of library window shows last visit date instead view-related visit date

RESOLVED DUPLICATE of bug 381519

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 381519
8 years ago
4 years ago

People

(Reporter: Igor Velkov, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090609 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090609 Minefield/3.6a1pre

When you choose folder in history view of library, that should not include latest visits (yesterday, or earlier month), and want to see a visit date field, and sort by date latest first, you see some records with date past then first border of your selection.
All records before date that start selected diapason will have visit count more that 1. I think it mean that no error in selectijn, but instead real visit date triggered selection there displayed last visit date.

Reproducible: Always

Steps to Reproduce:
1. have history for some period, preferable from day-to-day browsing. there should be some sites you visit on regular basis
2. go to history -> show all history
3. set to display visit date and visit count on the list pane, set sort by date
4. in tree pane chose any period should not include today
Actual Results:  
you see first some record with visit dates not fit into selection period, with visit count >1
only when you scroll list to first fit into period date, you see records with record count =1

Expected Results:  
If I use no grouping by site, every record in history should be displayed so many times so you visit it in selected period. "Visit date" should display date of every visit, not the last one.
Or, at least, if grouping is a "must have feature", last visit date should display the date of the last visit in desired period, not real last.
i'm pretty sure this is a dupe, there should be an old bug about results not returning dates based on query options.
Whiteboard: dupeme
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
couldn't find one, so confirming for now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Updated

6 years ago
Duplicate of this bug: 681578

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 381519

Updated

4 years ago
Whiteboard: dupeme

Comment 6

4 years ago
This is not a duplicate of bug 381519. Bug 604295 requests part of what this ticket is asking.
You need to log in before you can comment on or make changes to this bug.