Closed Bug 497313 Opened 11 years ago Closed 10 years ago

Leading/trailing whitespaces in custom.properties and mui.properties should be removed according to the spec of the properties files

Categories

(Firefox :: Installer, defect)

3.5 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: flod, Assigned: robert.strong.bugs)

References

Details

Attachments

(1 obsolete file)

Leading/trailing whitespaces in custom.properties and mui.properties are not ignored. We realized this issue after finding an extra whitespace in the menu item for "Safe mode" in a localized build (Italian).

This was already fixed for override.properties in bug 344148
Flags: wanted1.9.0.x?
Not sure if fixing this carries a risk of breaking locales that actually use the whitespace hanging around in custom.properties and the other one. Requesting wanted1.9.1.x, too.
Flags: wanted1.9.1.x?
Attached patch patch rev1 (obsolete) — Splinter Review
Axel, could you take a look at this especially regarding the affect it might have on locales.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #382569 - Flags: review?(l10n)
I found a few locales via grep that will be affected, I gotta do some test builds and go through a few install runs.

In regular strings that are displayed in a single UI blob, does the code remove surrounding whitespace at the windows layout level?
status1.9.1: --- → ?
Flags: wanted1.9.1.x?
Comment on attachment 382569 [details] [diff] [review]
patch rev1

Going to take care of this in bug 497313
Attachment #382569 - Attachment is obsolete: true
Attachment #382569 - Flags: review?(l10n)
Depends on: 570689
Flags: wanted1.9.0.x?
(In reply to comment #4)
> Comment on attachment 382569 [details] [diff] [review]
> patch rev1
> 
> Going to take care of this in bug 497313
bug 570689 that is
This is fixed on trunk by the landing of attachment #460994 [details] [diff] [review] in bug 570689 so resolving fixed.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
status1.9.1: ? → ---
Resolution: --- → FIXED
Duplicate of this bug: 619859
You need to log in before you can comment on or make changes to this bug.