The default bug view has changed. See this FAQ.

Bring back the toolbar buttons to the new Download Manager

RESOLVED WONTFIX

Status

SeaMonkey
Download & File Handling
--
enhancement
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: Rolf Bode-Meyer, Unassigned)

Tracking

Trunk
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.9.1pre) Gecko/20090610 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090610 SeaMonkey/2.0b1pre

Just installed todays nightly an realized that there now are (for me superfluous and even using up space when folded in) menu bar and a search field but the old buttons are missing.
I'd very much like to get back those buttons for open, open containing folder as I use them very often and they're more convenient than the context menu. There's enough room between the search bar and the Clear List button.

Reproducible: Always

Comment 1

8 years ago
What buttons? I don't remember any "open" or "open containing folder" buttons? Did you have an extension installed that supplied these buttons?
(Reporter)

Comment 2

8 years ago
Created attachment 385619 [details]
image of the old download manager - with buttons

No, standard Seamonkey, see attached image. It has buttons for Properties, Cancel, Launch FIle, Show File Location a.s.o.

Comment 3

8 years ago
> No, standard Seamonkey, see attached image. It has buttons for Properties,
> Cancel, Launch FIle, Show File Location a.s.o.
Yes but there are no "open" and "open containing folder" buttons as you originally stated.

Comment 4

8 years ago
> No, standard Seamonkey, see attached image. It has buttons for Properties,
> Cancel, Launch FIle, Show File Location a.s.o.
Yes but there are no "open" and "open containing folder" buttons as you originally stated.

Updated

8 years ago
Version: unspecified → Trunk

Updated

8 years ago
Depends on: 472001

Comment 5

8 years ago
> No, standard Seamonkey, see attached image. It has buttons for Properties,
> Cancel, Launch FIle, Show File Location a.s.o.
Yes but there are no "open" and "open containing folder" buttons as you
originally stated.

Obviously open and open containing folder were synonyms for Launch File and Show File Location. I use those two buttons a lot too and it would be nice to have them back.

Comment 6

8 years ago
The two buttons are missing in the download "progress window" too (which can be selected as an alternative to the download manager).  Most annoying to have to navigate to the download folder twice in a row (once to download, once to access the file).

This changed from SeaMonkey 2.0a3 to the current version:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: please give back the buttons on new Download Manager → Bring back the toolbar buttons to the new Download Manager

Comment 7

8 years ago
Philip: I intentionally haven't confirmed this one, as I consider it WONTFIX but want to hear about Beta 1 feedback before resolving as such.
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> I consider it WONTFIX

Because too low demand?
Is it that expensive adding the button (at least "open location", execute/open can be done by double clicking/pressing return on the entry) or do you just not see the benefit of it?

Comment 9

8 years ago
> Philip: I intentionally haven't confirmed this one, as I consider it WONTFIX
> but want to hear about Beta 1 feedback before resolving as such.

People in the MozillaZine SeaMonkey forums want the buttons in the progress window/dialog back.

Comment 10

8 years ago
But I think they're ugly and I removed them intentionally, in both the manager and the progress dialogs. That said, this bug is about the manager, not the progress windows.

Comment 11

8 years ago
Perhaps Philip could extend his toolbar customisation work to the download manager too, then we can all have whatever buttons we like ;-).

Comment 12

8 years ago
No, customization wouldn't help there, but you can write an extension to get them, this shouldn't be hard.

Comment 13

8 years ago
Though it's a pitty an extension is needed for this, I anyhow just made one:
http://www.eyrich-net.org/mozilla/mozapps.html#dlmgrbuttons

I nevertheless still hope for inclusion of these buttons in the app itself.
(Reporter)

Comment 14

8 years ago
(In reply to comment #13)
> I nevertheless still hope for inclusion of these buttons in the app itself.
It's nice to have such a extension, but I fear you just delivered a excuse for the developers not to fix this issue. :(

Updated

7 years ago
Blocks: 497379

Comment 15

7 years ago
We will not change this. 'Nuff said. WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.