When TB prompts for passwords at startup (IMAP w/ multiple accounts), prompts overlap and steal focus

RESOLVED DUPLICATE of bug 338549

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 338549
9 years ago
9 years ago

People

(Reporter: alessandro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Thunderbird (Shredder)3.0b3pre

This bug has probably been already filed, but I couldn't find the original thread.

With 2 or more IMAP accounts, if you don't save your passwords and TB is set to check mail at startup, last prompt will steal focus of the previous ones.


Reproducible: Always

Steps to Reproduce:
1. Create two IMAP accounts and don't save their passwords
2. Set TB to check mail at startup
Actual Results:  
Let's say you have two IMAP accounts: Account1 and Account2

1. TB shows prompt for Account1
2. TB shows prompt for Account2 (overlaps the prompt of Account1 and steals focus)
3. User enters password for Account2
4. Prompt of Account1 has lost focus and it's necessary to click on it to be able to type the password for Account1

Expected Results:  
1. Show prompt for Account1
2. Wait for the user to type the password
3. Show prompt for Account2
4. Wait for the user to type the second password
...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 338549
You need to log in before you can comment on or make changes to this bug.