image disappears during mouseover handler

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
4 years ago

People

(Reporter: ckmb, Assigned: bc)

Tracking

({helpwanted})

Details

(URL)

(Reporter)

Description

19 years ago
There are two pages which come out as disasters because of "mouse over item"
giving further information.

http://ninemsn.com.au
http://commbank.com.au

Less severely affected is
http://linuxstart.com
which simply loses the pictures when the mouse is over them.
(Reporter)

Updated

19 years ago

Comment 1

19 years ago
Mozilla will not support Layers
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
Summary: Layout disasters → [LAYER] Layout disasters

Comment 2

19 years ago
Hmm, I could only find layers in the first two URL's given. Adding evangwanted 
for those cases and reopening to examine the last remaining case (although I 
suspect it's a dup).  Please be sure to try again in new builds, as bug 48200 --
 the source of many similar image loading problems -- has just been fixed.
Status: RESOLVED → UNCONFIRMED
Keywords: evangwanted
Resolution: INVALID → ---
Summary: [LAYER] Layout disasters → Layout disasters

Comment 3

19 years ago
Why, if mozilla will not support layers, Bonsai uses layers ?!?!?!
(see
http://bonsai.mozilla.org/rview.cgi?cvsroot=/cvsroot&dir=mozilla/nsprpub/pr/src/pthreads&module=SeaMonkeyAll
for an example)
And why, if Netscape 4.7 supports layers, Mozilla will not ?

Comment 4

19 years ago
Because layers aren't part of the W3C spec (www.w3c.org) and there are ways to 
accomplish the same functionality that layers provided while still conforming 
to the spec.  No need to encourage old, propietary code.
(Reporter)

Comment 5

19 years ago
What about the disappearing pictures (animated gifs) which are supposed to
animate when the mouse hovers over them at the top of

http://linuxstart.com

These are not layers I believe.

Comment 6

18 years ago
need a minimized test case for http://linuxstart.com
initially guessing it's a javascript problem, but really need a smaller test
case to know for sure.
Not critical for NS6 RTM.  Marking future.
Assignee: clayton → jst
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Summary: Layout disasters → image disappears during mouseover handler
Target Milestone: --- → Future
The images on linuxstart.com now seem to animate when moused ower and the
problems on the other sites mentioned here need some evangelising so that the
sites stop feeding mozilla/netscape 6 layer HTML/code...

Reassigning to the Evangelism component...
Assignee: jst → blakeross
Component: Layout → Evangelism
QA Contact: petersen → zach

Comment 8

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Keywords: evangwanted
Hardware: PC → All

Comment 9

18 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Comment 10

18 years ago
The images on linuxstart now animate correctly but the first image over "add a
site" is invisible until the mouse is over it and then disappears again once the
mouse is off it.

It has been exhibiting this for some time now.

Build 2001051921 mozilla-i686-pc-linux-gnu.tar.gz

Comment 11

18 years ago
DUP of 32269

Comment 12

18 years ago
In 0.9.1, this bug still seems present. For example, see <a
href="http://dac.shrimpwars.be">http://dac.shrimpwars.be</a>. The buttons on the
left disappear as the page is loaded.
(Assignee)

Comment 13

18 years ago
Ishtar. 

Re dac.shrimpwars.de, the page has seriously horked HTML. See
http://validator.w3.org/check?uri=http%3A%2F%2Fdac.shrimpwars.be%2F&doctype=Inline.
While I do see the mouseover behaviour you describe in Mozilla and not in IE, it
is not clear as to the cause due to the all of the invalid HTML. We will look at
this when we have more time but due to limited evangelists and higher priority
sites we will have to defer analysing dac.shrimpwars.be's problems until later.

If you think this is a bug in the browser you should file a bug against the
appropriate component.  It appears that the original image is removed before the
new image is loaded/displayed but it is not clear why.

Evangelism bugs should be filed on a per site basis so that the site can be
analysed, contacted, fixed and the bug resolved so we know the site is fixed.
When we continue adding new sites to an evangelism bug it is not clear which
site has been contacted, which site has been fixed etc.

If you think this is an evangelism issue, you could take the offending page,
save it locally, fix up the HTML so that it validates and then create a *new*
evangelism bug and attach the HTML to the *new* evangelism bug for the site that
would help us determine what is going wrong.

Thanks
(Assignee)

Comment 14

18 years ago
Since this bug has collected a number of sites and it is not clear what is
happening any more and it appears that linuxstart has been fixed I am going to
mark it fixed.  The other sites mentioned in this site should have new
evangelism bugs filed on them if they are still broken.
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

18 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Target Milestone: Future → ---
Version: other → unspecified
v
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.