Don't show Collector promos in non-Firefox views

VERIFIED FIXED in 5.0.8

Status

defect
P2
normal
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: fligtar, Assigned: clouserw)

Tracking

unspecified
5.0.8

Details

Attachments

(1 attachment)

Reporter

Description

10 years ago
At least one person has installed the extension in Thunderbird (which it doesn't support) so we should hide the sidebar panels for the Collector from the directory and other collections pages if the user isn't browsing in /firefox.

We should also hide the line in the Add to Favorites lightbox that references the Collector when non-Firefox, but this might be harder to do with one l10n string, so that part's optional.
Reporter

Updated

10 years ago
Priority: -- → P2
Target Milestone: --- → 5.0.8
Reporter

Updated

10 years ago
Duplicate of this bug: 505110
Assignee

Comment 2

10 years ago
This removes the sidebars from the faq and features pages as well as the collector directory sidebar and collection detail pages.  It doesn't remove it from the collector page itself (/pages/collector) since if you go there it seems like you'd like to see it.  r? to see if you want anything changed
Assignee: nobody → clouserw
Attachment #389968 - Flags: review?(fligtar)
Reporter

Comment 3

10 years ago
Comment on attachment 389968 [details] [diff] [review]
check for firefox

Looks good!
Attachment #389968 - Flags: review?(fligtar) → review+
Assignee

Comment 4

10 years ago
thanks, r30273
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Reporter

Updated

9 years ago
Component: Collections → Collector Extension
Version: 3.2 → unspecified
QA Contact: collections → collector-extension
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.