Activity Manager / statusbar message "Deleted x message(s) from [Drafts...]" can cause user confusion (users think there is dataloss)

NEW
Unassigned

Status

--
minor
9 years ago
a year ago

People

(Reporter: bugzilla2007, Unassigned)

Tracking

(Blocks: 1 bug, {polish})

Trunk
polish

Thunderbird Tracking Flags

(thunderbird3.1 ?)

Details

(Whiteboard: [gs], URL)

Attachments

(1 attachment, 1 obsolete attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090608 Shredder/3.0b3pre

When sending a message that has been automatically or manually saved to draft folder, the last status bar feedback to the user is "Deleted 1 message". While technically correct (the draft message was deleted after sending), this may confuse users and cause bad feelings that Thunderbird deleted something the user isn't aware of. We'll need some way of suppressing this or blanking it out after the event.



Reproducible: Always

Steps to Reproduce:
1. compose mail, save to draft manually (for most users, autosave will cause the same effect)
2. send mail
3. watch status bar feedback
Actual Results:  
Status bar's last feedback is:
"Deleted 1 message"
This (negative) feedback stays (!) until the user does something which causes status bar to blank out or show something else.
User wonders why Thunderbird deleted something (and what?) without being told to.

Expected Results:  
Status bar should be blank or show some positive feedback after successfully sending a mail
Component: General → Mail Window Front End
QA Contact: general → front-end
(Reporter)

Comment 1

9 years ago
Any feedback on this one?
Using 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090719 Lightning/1.0pre Shredder/3.0b4pre ID:20090719111731

this isn't current behavior, but status bar is cleaned as you want, and previous the bar display "copied mail to sent box".

This is invalid.

Reporter, feel free to reopen it if I'm wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090720 Shredder/3.1a1pre

I can reproduce this every time with the current nightly as above.
Note that I am not having Lightning extension installed, which may or may not play a role. The only two existing extensions in my configuration (accountEx, virtual identity) are "incompatible with tb3" and therefore disabled.

Steps: [No Lightning installed]
1.) main window, look at your inbox
2.) click on "write" new message
3.) compose to yourself, add subject, click on "save" as draft
4.) click on "send" and DO NOT move your mouse at all after that (important)(alternatively, use ctrl+enter to send, but I didn't check that)

Actual Results:
- first status messages including "message sucessfully sent" appear correctly in status bar of /compose window/
- status message "deleted 1 message from draft folder" appears in status bar of /main window/ (!) and stays until you do something which overwrites status bar, e.g. hover over link in preview
- if you repeat steps without blanking out main window status bar in between, thunderbird will even start counting the deleted messages, and you'll get
"Deleted 2 messages from draft folder" etc. in main window status bar, which I find useless and wrong.

Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Hi Thomas.

I cannot confirm using in safe-mode

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090720 Lightning/1.0pre Shredder/3.0b4pre ID:20090720035214

(not 3.1a1pre but 3.0b4pre)

Only in activity manager I see what you write (see screenshot attached).

Wayne can you reproduce this bug?
Created attachment 389645 [details]
screenshot
Looks like a Trunk issue and not a 1.9.1 issue
Version: unspecified → Trunk

Comment 7

8 years ago
I switched to 3.0.4 yesterday (from 2.x) and am now getting these status messages. Not just when I send the message, but also every time I save it. Sometimes several are counted together and the status messages go "Deleted 1 message in Drafts", "Deleted 2 messages in Drafts", ..., increasing by one every time I save.

I think this should be raised from "minor". It's a pretty scary message to get. It was left standing in the status bar for long enough that I didn't immediately realize it had occurred in the context of saving a draft (and even if it hadn't, the average user would probably not understand the connection). I had just recovered from my frustration with the new indexer apparently indexing every one of my numerous big folders twice, taking the better part of a day, when I got this message; my spontaneous reaction was to just go back to 2.x (I didn't). I pulled an old version of my Drafts folder from a backup and did a diff before I realized what the message meant. If that happens to me, a lot of less-techy users are going to be put off by this.

Updated

8 years ago
Duplicate of this bug: 563289

Updated

8 years ago
Keywords: polish
OS: Windows XP → All
Hardware: x86 → All
Summary: "Deleted 1 message" in status bar is not a nice feedback after sending a message whose draft was saved → Activity Manager\statusbar message "Deleted x message in ..." can causes user confusion

Comment 9

8 years ago
I'm copypasting my report from bug 563289 into this bug. I also think the bug is more severe than "minor". People are seeing messages like "Deleted 11 messages in Drafts" and they're freaking out - see the links to various forum threads below. 

If you don't do anything to overwrite the status bar (eg. automatically check for mail every x minutes) this message will constantly be there while composing a message, and the count of deleted messages will increment every time the message is auto-saved...

=====

While composing mail, users may see the status message "Deleted N Messages from
Drafts" from time to time in the status bar, where N may be any number. The
message can also be seen in the Activity Manager window. This message causes
confusion for users who have their account settings set to "Don't delete any
messages", and worry that Thunderbird is auto-deleting their manually saved
unsent messages regardless.

The message is related to Auto-save drafts. It seems that each time a mail
message is auto-saved, a status message regarding the deletion of the previous
auto-save draft is generated.

It is particularly worrisome for users who may have many manually saved drafts,
and cannot tell which messages have been deleted, or why.

IMAP users may not notice this status message, since it is normally immediately
overwritten by a "user@example.com is up to date" status message in the status
bar. However, it can still be found in the Activity Manager window. POP users
will see the message remaining in the status bar.

It seems to the user that this message has appeared at random, since it's not
related to a user action such as pressing "send". It's generated at the
auto-save timer interval, and then, only if the user has made changes to the
mail message in the past interval - so this behavior can seem quite random.
There is no indication that it relates only to previous auto-save draft
versions rather than manually saved drafts, and there are no status messages
regarding the auto-saving of messages that might explain or "balance out" the
deletion messages. Adding to this confusion is the fact that there is a
cumulative count if no other activity takes place. In other words, if the user
has been composing a message for 30 minutes, they might glance at the status
bar and notice it reads "Deleted 5 messages from Drafts".

There are numerous complaints about this in help forums, mostly unanswered,
eg.:
http://forums.mozillazine.org/viewtopic.php?f=39&t=1821715
http://getsatisfaction.com/mozilla_messaging/topics/drafts_are_being_deleted_how_to_i_stop_this

This occurs in all versions of Thunderbird 3 on the Mac, and most likely on
other platforms (haven't tested).

Reproducible: Always

Steps to Reproduce:
1. using default settings, begin composing a mail message, continually making
changes.
2. after ten minutes or more, look at the status bar (POP account) and/or the
Activity Manager.
3.
Actual Results:  
a message indicating "Deleted N messages from Drafts" appears, causing user
concern.

Expected Results:  
a more informative message could be displayed, perhaps distinguishing deletion
of previous auto-save versions from deletion of manually saved messages; or
perhaps no message at all if deleting a previous version of an auto-save draft.
This confirms my pov that albeit technically correct, the status bar message is causing a lot of confusion to users. Some users on http://gsfn.us/t/pgk6 even claim they've had unwanted dataloss, which I think is not the case (we only delete a draft after sending a message, which seems correct behaviour.)
-> confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [gs]
(Reporter)

Updated

8 years ago
Severity: minor → normal
(Reporter)

Updated

8 years ago
Attachment #389645 - Attachment is obsolete: true
(In reply to comment #6)
> Looks like a Trunk issue and not a 1.9.1 issue

btw, I just confirmed this for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100825 Lightning/1.0b2 Thunderbird/3.1.3, so it's not just a trunk issue.

Steps to reproduce
1. Compose msg
2. Ctrl+S (File > Save) to save as draft
3. Send message (and do not click nor even move your mouse after that, plus ensure that this doesn't coincide with automatical downloading of new messages which will spoil the effect as it overwrites the status bar)
4. Watch status bar feedback (after sending!)

Actual result:
"Deleted 1 message from Drafts"
What TB is trying to say is that it removed (deleted) the draft of the message you have just sent, which is correct and expected behaviour. However, the message is unexpected and misleading, so this is where users start worrying if something was deleted against their will which they wanted to keep. Which is NOT the case.

Expected result
After sending a message, the last status bar feedback should be either
- no feedback (empty status bar)
- or success feedback about sending (probably nicer)
(Reporter)

Updated

8 years ago
Summary: Activity Manager\statusbar message "Deleted x message in ..." can causes user confusion → Activity Manager\statusbar message "Deleted x message(s) from..." can cause user confusion (users think there is dataloss)
status-thunderbird3.1: --- → ?
(Reporter)

Updated

8 years ago
Summary: Activity Manager\statusbar message "Deleted x message(s) from..." can cause user confusion (users think there is dataloss) → Activity Manager / statusbar message "Deleted x message(s) from [Drafts...]" can cause user confusion (users think there is dataloss)
(Reporter)

Updated

8 years ago
See Also: → bug 397910
OK folks, be aware that some IMAP losers of 3.0.x actually ARE facing dataloss, because of this bad guy which has been claimed fixed for 3.1:

Bug 397910 - Message Drafts Not Saved When Composed Offline

http://getsatisfaction.com/mozilla_messaging/tags/bug_397910
http://getsatisfaction.com/mozilla_messaging/tags/bug_497952

We need to communicate much more clearly about these bugs, users are
getting really angry them in GS; what's worse, users are mixing up the two issues, really big confusion on GS, and many reports for both of them. Users who saw the harmless status bar thing (this bug) think they have lost messages
(but they haven't). Users who really have dataloss because of bug 397910
have commented in topics about the bad status bar message (which is harmless). I've tried to tag as many topics as I could find about this, sometimes with both bugs so that we have easier reference. Someone needs to do some merging in getsatisfaction.
(In reply to comment #12)
> OK folks, be aware that some IMAP losers of 3.0.x actually ARE facing dataloss
yay, that's IMAP *users* but they lose out anyway...

Comment 14

8 years ago
Thanks for reporting this, Thomas.  IMHO, the idea that Activity Manager shows a Draft message deleted when one is edited and sent on its way, is only part of the issue.  While that may be "technically" correct, the fact is that my attachment shows four messages deleted when I only sent one.  Therefore, it isn't even technically correct.  This shows a programming flaw that is very serious.  If a computer counts wrong for any reason, the software is wrong 99.999% of the time.  In this case, there is no doubt that it is the software.  But now we worry what layer is causing the problem.  This appears to be an accounting error, a data integrity issue, and a PR nightmare.  This should go to the top of the pile immediately, if only to find a plausible reason for this behavior so as to reassure users that their data is safe.  While I could find no deleted messages in the trash, I now wonder if it bypasses the trash.

Comment 15

8 years ago
Created attachment 480842 [details]
Activity Manager with deleted Drafts

From:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.9) Gecko/20100916 Lightning/1.0b2 Lanikai/3.1.4

Comment 16

8 years ago
KitchM, please see comment 9 for an explanation of why there are multiple deleted messages reported.

It has to do with auto-save; every time a message is auto-saved in "Drafts" while you are composing a message (eg. every ten minutes) the previous auto-saved draft is deleted, and this gets reported in the status bar. This happens the whole time you're composing a message, not only after you press "send". The count is cumulative if you don't clear the status bar with some other activity. So, there is no mystery as to what is causing that behaviour, and there is no actual data loss from it.

Still, its a bug that is quite disturbing to those who, like you, experience it and don't know the explanation, and it does need to be fixed.

Comment 17

8 years ago
Thanks, Sum.  That is much clearer, and I appreciate the explaination.

Should drafts even be autosaving if one is not working on a draft edit, or is that exactly what I must have been doing?  Or perhaps you meant that when any message is being created/edited, the autosave file is placed in the "Drafts" mailbox and then deleted from there on the next autosave?

If this is normal behavior, would it be better to have the information in the activity monitor say something more explanitory and accurate?  That might just clear this up without any major coding  More like a rewording of the internal message list in the code?  ("Autosave deleted old copy from Drafts")

Thanks again.

Updated

7 years ago
Severity: normal → minor

Updated

6 years ago
Blocks: 812827
(Reporter)

Updated

4 years ago
Duplicate of this bug: 997427

Updated

3 years ago
See Also: → bug 484407

Updated

3 years ago
See Also: bug 484407

Comment 19

a year ago
This issue is totally confusing for users.
In particular, a few months ago, my mother using drafts a lot was freaked out by this message appearing out of nowhere and seemingly randomly. She was thinking previous drafts were deleted.
I had to explain to her that no draft was deleted (I did not know about this bug report yet) and that this was likely due to
some internal operation of Thunderbird.
Still, this really needs to be fixed as it is still present in current Firefox.
Scaring people is not the way to go.
You need to log in before you can comment on or make changes to this bug.