Closed Bug 498111 Opened 10 years ago Closed 8 years ago

Keyword usage of bookmarks interferes with auto-completion of urlbar / addressbar

Categories

(SeaMonkey :: Autocomplete, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: prof, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [Halloween2011Bug])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1pre) Gecko/20090612 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1pre) Gecko/20090612 SeaMonkey/2.0b1pre

Having a certain website in the history and auto-complete for typing is switched on:
If this website has the letter at the beginning which is a keyword used for a bookmark (NOT matching the website in the history, but a completely other website), the website from the history is being opened instead the bookmark from the keyword being used.
The auto-complete does NOT show the website of the history in the url-bar after "finalizing" the keyword with a space, so I'm not quite sure if this is a problem with the auto-complete itsself rather than something else. But anyway the website from the history is being opened.


Reproducible: Always

Steps to Reproduce:
0. Configure SM to fill in the best match in the url bar while typing (to make sure to have the same like me: completion of previously typed URLs only, and beginning of web-address only)
1. create any bookmark with a letter as keyword (e.g.: the letter 'm' as keyword)
2. visit a url which has that letter from step 1 at the beginning (e.g. monoteque.de )
3. try to access the bookmark via it's keyword 'm' (without the apostrophes)
3.1. typing m (Seamonkey now offers monoteque.de via auto-complete)
3.2. typing a space (Seamonkey removes it's suggestion)
3.3. Hit <enter>
Actual Results:  
Seamonkey opens monoteque.de although it has been visually removed this suggestion

Expected Results:  
Seamonkey opens the url of the bookmark which has the keyword m

This is some kind of regression due to the new urlbar, it used to work fine in SM1.1.x. 
When using a space after the keyword-letter the corresponding bookmark was called.
Keywords: regression
Version: unspecified → Trunk
(Fwiw, did bug 494169 make a difference, one way or the other?)

Can you reproduce with Firefox current v3.5(rc1)pre?
Flags: wanted-seamonkey2?
Not wanting bugs that have no useful summary.
Flags: wanted-seamonkey2? → wanted-seamonkey2-
Summary: Keyword → Keyword usage of bookmarks interferes with auto-completion of urlbar / addressbar
Whoops, sry about the summary, it was not meant to be a single word only. Looks like I stripped something by copy and pasting...

@#1: I tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090615 Shiretoko/3.5pre and that one is a real "smarty", it doesn't autocomplete at all if the current entry in the urlbar matches a keyword of a bookmark. 
For me it would be enough if that "hidden" auto-completion after pressing space after a keyword wouldn't happen, but I guess that way Firefox3.5pre does it now would be fine too. 

Gecko/20090615 SeaMonkey/2.0b1pre still has the issue.
Seamonkey2.0a3 had it, too. (which was before https://bugzilla.mozilla.org/show_bug.cgi?id=494169 I guess)
We will very probably need to convert bookmarks to the places backend to do that, so I don't much chance for a change in 2.0 (places bookmarks are planned for the next release after that).
Depends on: SMPlacesBMarks
Is it possible to fix the bug for SM2.0 then at least concerning the "hidden" auto-completion? When space is being pressed and the inline-auto-completion/suggestion is therefore removed from the urlbar (correct behaviour until then), SM should not open a webpage which is not even presented to the user any longer (like SM1 did correctly). It should only try to use the keyword or open the "domain" (which will lead to nothing of course in case of the example).
I think this is a dupe of bug 481843 (which is not marked as a regression yet but older than this one).

I also agree with comment 5. We probably won't have bookmarks support in the location bar for 2.0 but keywords really shouldn't be broken, whether used with a space or not (mind you, keywords don't necessarily have to be parameterized).
Yes, but I wonder how keywords without using space should be detected (without having "places bookmarks" like #4 mentioned) if inline-auto-completion is turned on. 
If this is possible anyways: fine.
If not: at least "finalizing" by space should be a working solution.

481843 does not really seem to be the same as it auto-completes wrongly/not as expected. But this bug is more focused on the fact that a url is being opened which is visually already removed (therefore auto-complete gone). 
The browser should never call a url which it does not indicate as going to be loaded to the user.
This has possibly been fixed by bug 498596 in current nightlies, SeaMonkey 2.1 Alpha 3 and later - could someone who uses autocomplete this was please double-check?
Hmm, I'm having a hard time reproducing this at all, even with SM 2.0 (latest nightly). commander_keen, can you?
Can still reproduce this with SM2.0.6

Can't test with current 2.1nightly as the profile-screen is broken which doesn't allow to proceed. 
Cannot find any Alpha3, neither on the website nor candidate builds on the FTP-server. Please point me to a working build (including screen to choose profile) which is new enough and I'm willing to test again.
Can't reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.13pre) Gecko/20100831 SeaMonkey/2.0.8pre.

Created a bookmark with keyword m, if I type m in the urlbar it's autocompleted to mxr.mozilla.org for me. If I then press space I only see m and after pressing m I get to the bookmark URL.
commander_keen, can you try to reproduce it with a current nightly or SeaMonkey 2.1 beta1? You can find it at http://www.seamonkey-project.org/releases/seamonkey2.1b1/
Whiteboard: [CLOSEME 2011-02-01 WFM]
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101129 Firefox/4.0b8pre SeaMonkey/2.1b2pre

The described behaviour changed in such a way that there is no auto-completion at all after typing m in my example. (step 3.1) 
I need to type a second letter to get the inline-auto-completion. This should not be necessary(?), autocomplete should work right from the start with the first letter.

Interesting thing is, that the following letters cause auto-complete to fail here: e m n s u  (I didn't know domains with x at the beginning to test), all others seem to work.
I reproduced this for the letter m on a totally fresh profile!
WORKSFORME
1) In Preferences - Browser - Location Bar I set "Match only websites you've typed previously" and Match: "Only at the beginning of the location or title".
2) Added this page to Bookmarks and assign it keyword m
3) Visited monoteque.de
4) Opened new window, typed m, list of suggestions appeared, keyword bookmark first in it, then press space, positions not changed, press enter - bookmarked page opened.
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [CLOSEME 2011-02-01 WFM] → [Halloween2011Bug]
It has been fixed at some time it seems, can confirm with 
Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1
Resolution: WORKSFORME → FIXED
(In reply to commander_keen from comment #15)
> It has been fixed at some time it seems, can confirm with 
> Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20110928 Firefox/7.0.1
> SeaMonkey/2.4.1

Unless we know which specific bug fixed it then have to mark as WORKSFORME, if you know the bug number then this can be marked as a DUPLICATE instead
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.