Need to implement updated media timeline support

RESOLVED INVALID

Status

()

Core
Audio/Video: Playback
RESOLVED INVALID
8 years ago
a year ago

People

(Reporter: cajbir, Unassigned)

Tracking

({html5})

Trunk
html5
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
The WHATWG specification has changed to add a 'startTime' attribute to the MediaElement. This needs to be implemented.

http://www.whatwg.org/specs/web-apps/current-work/multipage/video.html#dom-media-starttime
Duplicate of this bug: 521899
We're out of date with the current HTML video spec. The timeline (i.e. the
values of HTMLMediaElement.currentTime) of a video/audio should go from the
"earliest possible position" to the las possible position. We currently always
have the playback position starting a 0 and ending at duration.
This seems like a somewhat unfortunate thing for the spec, I bet everyone's going to get it wrong because it won't be common. :( I can't help but wonder if it would be better to have a startTimeOffset property, so that .currentTime et al are all still have a timeline starting from 0, and if you want the "real" time you'd use .currentTime + .startTimeOffset.

I'd also suspect we'll want the default video controls to normalize everything to 0 (.currentTime - .startTime), since it would be really confusing otherwise.
I totally agree with comment #3.
Duplicate of this bug: 503802
Duplicate of this bug: 566375
When this bug is fixed, the following test should pass:
(Note that the tests current sniff the user agent for Firefox--hopefully that'll be fixed soon.)

http://test.w3.org/html/tests/submission/Microsoft/video/video_008.htm

Updated

7 years ago
Duplicate of this bug: 589565

Updated

7 years ago
Blocks: 554013
Keywords: html5

Comment 9

7 years ago
ietestcenter url: http://samples.msdn.microsoft.com/ietestcenter/html5/MediaElements/media-rules-seeking.3.htm
Duplicate of this bug: 603034
Spec changed again, morphing this bug to track the current state.
Summary: HTMLMediaElement needs startTime attribute to be implemented → Need to implement updated media timeline (initialTime, startOffsetTime) support
Duplicate of this bug: 635569

Comment 13

6 years ago
Any new developments here?
(Reporter)

Comment 14

6 years ago
I'd be reluctant to start implementing this part of the spec until things like multitrack, media controller, streams, etc are less of a moving target. It's likely to be in a bit of flux.
(Reporter)

Comment 15

6 years ago
I'm adding 'initialTime' as part of the implementation of temporal media fragments in bug 648595.
Depends on: 648595

Comment 16

5 years ago
I recently did some experimental work on synchronising events to live streams, and I patched Firefox to implement startOffsetTime for WebM streams.

https://github.com/bbcrd/HTML5-MediaElement-startOffsetTime

I do agree that the spec needs some clarification. My colleague Sean O'Halpin blogged about this:

http://www.bbc.co.uk/blogs/researchanddevelopment/2012/02/what-does-currenttime-mean-in.shtml

http://www.bbc.co.uk/blogs/researchanddevelopment/2012/01/implementing-startoffsettime-f.shtml
Keywords: dev-doc-needed
Summary: Need to implement updated media timeline (initialTime, startOffsetTime) support → Need to implement updated media timeline support

Comment 17

4 years ago
It's been some time and I guess the spec has stabilized. If there are still outstandind issues, did anybody file bugs?
Component: Audio/Video → Audio/Video: Playback
This is no longer a requirement of the spec.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.