Paste from MS Excel/Word or OOo Writer/Calc broken

RESOLVED INCOMPLETE

Status

Thunderbird
Message Compose Window
--
major
RESOLVED INCOMPLETE
9 years ago
5 years ago

People

(Reporter: Massimo Santoro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-06-30)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99
Build Identifier: 2.0.0.21 - 3.0b2

Paste from MS Word or OOs Writer is just plain text to Thunderbird 2.0.0.21, while it's formatted almost ok (borders in table missing) in Thunderbird 3.0b2.

From MS Excel or OOs Calc instead is still always plain text both on 2.0.0.21 and 3.0b2. Copy/Pasting From Writer to Calc (or even from MS Excel to MS Word) and then from Writer to Thunderbird 3.0b2 is ok. Still broken to Thunderbird 2.0.0.21.

Reproducible: Always

Steps to Reproduce:
1. start writing text on any word processor _and_ in a spreadsheet, using colors and/or bold text (try both)
2. copy that text
3. paste it on message composer in Thunderbird 2.0.0.21 and see the effects
Actual Results:  
Unformatted text is pasted

Expected Results:  
Formatted text is expected

Our clients cannot switch from Outlook Express to Thunderbird because of this bug. It's really serious to them since they copy&paste 100-200 emails each a day from spreadsheets (we talk about 30 people doing this everyday).
Massimo can attach a testcase (*.xls to copy and past to TB)?

Updated

8 years ago
Whiteboard: closeme 2010-06-30
RESOLVED INCOMPLETE do to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 3

5 years ago
This still seems to be present, tested with Thunderbird 17.0 and Excel 2010.  Formatting is lost.

Odd thing; generating a spreadsheet with formatting in Excel, pasting into Word, then pasting into Thunderbird works okay... not sure what's up with that, but I'm guessing it is because Excel and Word grab that data into the copy buffer in different ways, Word being the one that Thunderbird "understands" better when pasting.  Any ideas?
You need to log in before you can comment on or make changes to this bug.