Message preview no longer working (since bug 474701)

RESOLVED INVALID

Status

Thunderbird
Folder and Message Lists
--
blocker
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Alfred Kayser, Unassigned)

Tracking

(Blocks: 1 bug)

Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 383885 [details]
Error Console dump

From 2009/06/14 onwards, with the current TB nightly the preview message pane doesn't work. Selecting a message in the ThreadPane, or selecting FolderPane no longer displays the corresponding message in the preview pane.

Error Console generates messages such as:
this.parentNode.view.selection is null
b.view.selection is null
gHaveLoadedMessage is not defined
GetFirstSelectedMessage is not defined
gRightMouseButtonDown is not defined.

This all looks like an incomplete patch applied on the nightlies.

Tested with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090617 Lightning/1.0pre Shredder/3.0b3pre ThunderBrowse/3.2.5

This is probably caused by bug 474701, so marking this blocking bug 4971199.

As this issue renders TB nightly completely useless, marking all blocking flags...
Flags: blocking-thunderbird3?
Does this occur in safe mode? Also, try with a later nightly.
(Reporter)

Comment 2

9 years ago
There are two extensions that cause problems:
1. ThunderBrowse 3.2.5 is the real culprit here.
2. Display Mail User Agent 1.6.4.2 prevents the display the message header.

The first is surely related to the changes from bug 474701.

P.s. The TB version I tested with is the latest nightly according to the 'Check for Updates' of Shredder.

For ThunderBrowse there is a version 3.2.6 on his site fixes the problem so marking this one as 'FIXED'. At this moment, the update is probably stuck in the review process of AMO...
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
-> Invalid since it's not a Thunderbird issue.
Resolution: FIXED → INVALID
Flags: blocking-thunderbird3? → blocking-thunderbird3-
You need to log in before you can comment on or make changes to this bug.