mochitest-chrome: test_close_download_manager.xul times out intermittently

RESOLVED FIXED in mozilla1.9.2a1

Status

()

defect
--
major
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: karlt, Assigned: enndeakin)

Tracking

({intermittent-failure, regression})

Trunk
mozilla1.9.2a1
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

6903 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul | Test timed out.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1245463305.1245470641.23363.gz#err1
Linux mozilla-central unit test on 2009/06/19 19:01:45

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1245465343.1245467340.17574.gz
Linux mozilla-central test everythingelse on 2009/06/19 19:35:43
(Reporter)

Updated

10 years ago
Whiteboard: [orange]

Updated

10 years ago
Duplicate of this bug: 499569

Comment 2

10 years ago
again http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1245592150.1245598889.13049.gz

Linux mozilla-central unit test on 2009/06/21 06:49:10
Linux mozilla-central unit test on 2009/06/23 21:37:39
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1245818259.1245825254.9458.gz&fulltext=1

6905 INFO Running chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul...
6906 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul | DMUI closes with ESC key

command timed out: 1200 seconds without output, killing pid 7014
process killed by signal 9
So, this test wasn't random before, and no download manager code has changed as far as I know.  This seems to have started up a few days after the focus refactoring landed (bug 178324).  Did that maybe change how we handle the closing of windows?

Ted - can you use your magical script and see when this first started to show up please?
{
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1245859601.1245862503.29286.gz
Linux mozilla-central test everythingelse on 2009/06/24 09:06:41

6905 INFO Running chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul...
6906 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/mozapps/downloads/tests/chrome/test_close_download_manager.xul | DMUI closes with ESC key

command timed out: 1200 seconds without output, killing pid 2232
process killed by signal 9
}

Please, fix or disable tests which abort the suite.
Severity: normal → major
Summary: test_close_download_manager.xul times out intermittently → mochitest-chrome: test_close_download_manager.xul times out intermittently
(In reply to comment #7)
> Ted - can you use your magical script and see when this first started to show
> up please?

I updated the db and sent you the URL in #developers. Did you get a chance to look at it?
I kept getting timeouts and connection resets sadly :(
Got the results - looks like this started 6/10 when the focus handling refactoring landed.
Blocks: 178324
(Assignee)

Comment 12

10 years ago
On Linux, window focusing can occur after the load event and other things have occurred.

To fix this we can just call focus() manually on the downloadManagerWindow before sending keys at it.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #385163 - Flags: review?(sdwilsh)
Comment on attachment 385163 [details] [diff] [review]
focus window first

r=sdwilsh
Attachment #385163 - Flags: review?(sdwilsh) → review+
(Assignee)

Comment 15

10 years ago
Hopefully. Let's reopen if we see it again.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.2a1
(Reporter)

Updated

10 years ago
Depends on: 497839
(Reporter)

Updated

10 years ago
Depends on: 506175
(Reporter)

Updated

10 years ago
No longer depends on: 497839
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.