Closed Bug 499599 Opened 12 years ago Closed 12 years ago

hiding parentElement setting visibility:hidden of some DIV having overflow:scroll leaves scrollbars of DIV visible while hiding the content

Categories

(Camino Graveyard :: HTML Form Controls, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 187435

People

(Reporter: lgxxl, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

hiding parentElement setting visibility:hidden of some DIV having overflow:scroll leaves scrollbars of DIV visible while hiding the content:

I have a DIV "position:fixed" and it contains another DIV which has overflow set to "scroll". when I set the visibility of the parent DIV to "hidden" everything (also the content of the sub-DIV) hides correctly but the scrollbars of the sub-DIV still remain visible as artefacts, which is really annoying cause the content disappeared already! setting the visibility explicitly for the sub-DIV seems to be a valid workaround.



Reproducible: Always

Steps to Reproduce:
1. <div id="mytopdiv" style="position:fixed;top:10px;left:10px;height:200px;width:200px;"><div id="mysubdiv" style="width:100px;height:100px;overflow:scroll;">Halleluja here you have to paste some Text so that 100x100 pixels get more than filled and you need to scroll... to see everything.</div></div>
2. execute in javascript document.getElementById('mytopdiv').visibility = "hidden";
3. the scrollbars of the 'mysubdiv' are still visible though they should be hidden too.

Actual Results:  
scrollbars are not hidden as expected.

Expected Results:  
scrollbars should hide too if the parent element is hidden.

apply the visibility not only to content but also to the scrollbars.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187435
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8) Gecko/20051111 Firefox/1.5
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8) Gecko/20051111 Firefox/1.5

Note that this bug would be expected in Firefox 1.5 and equivalent Camino versions, and in the future, please file bugs with the version of Camino that exhibits the bug (if possible).

cl
Status: RESOLVED → VERIFIED
Just for testing if bug still remains. It is easy to check here!
The bugf is in my Version 1.6.7Int (1.8.1.21 2009032711) of camino.
You need to log in before you can comment on or make changes to this bug.