Closed Bug 499724 Opened 12 years ago Closed 12 years ago

Update doesn't work if `Auto-detect proxy settings for this network' is selected

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 47188

People

(Reporter: hadrabap, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; cs-cz) AppleWebKit/530.18 (KHTML, like Gecko) Version/4.0.1 Safari/530.18
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.11) Gecko/2009060214 Firefox/3.0.11

When `Auto-detect proxy settings for this network' is selected in Advanced|Network settings tab:
 - manual update returns `AUS: Update XML File Malformed (200)'
 - auto-update is not working.

Computer is connected to internet using xDSL line using WiFi AP (NAT). Please note that internet (HTTP, HTTPS, FTP, FTPS) is working properly in this network with both `Auto-detect proxy settings for this network' and `No proxy' options.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox
2. Go to Firefox|Preferences…
3. Go to Advanced|Network tab
4. Click Settings… button in Connection group
5. Choose `Auto-detect proxy settings for this network'
6. Click OK
7. Close Preferences window
8. Restart Firefox
9. Click Help|Check for Updates…
10. Error message "AUS: Update XML File Malformed (200)" will appear

--

11. Go back to Preferences
12. Set No Proxy in Proxy configuration dialog
13. Click OK
14. Close Preferences window
15. Choose Help|Check for Updates…
16. Update is working properly.

--

17. Restart Firefox
18. Choose Help|Check for Updates…
19. Update is working properly.

Actual Results:  
Error message "AUS: Update XML File Malformed (200)"


Expected Results:  
Regular Updater message (new updates or up-to-date message)

Also happened in 3.0.10 version.
discussed in bug 471889 (even though that report has different steps to reproduce)
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 47188
You need to log in before you can comment on or make changes to this bug.