drag of message from Search Messages fails with error "GetSelectedMessages is not defined" messengerdnd.js Line: 452

VERIFIED FIXED in Thunderbird 3.0b4

Status

MailNews Core
Search
--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: wsmwk, Assigned: sid0)

Tracking

(Blocks: 2 bugs, {regression})

Trunk
Thunderbird 3.0b4
regression
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +
in-testsuite ?
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Error: GetSelectedMessages is not defined
Source File: chrome://messenger/content/messengerdnd.js
Line: 452

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1pre) Gecko/20090621 Shredder/3.0b3pre
(Reporter)

Updated

9 years ago
Blocks: 497199

Updated

9 years ago
OS: Windows Vista → All
Hardware: x86 → All
(Assignee)

Comment 1

9 years ago
Created attachment 386129 [details] [diff] [review]
possible fix

<http://mxr.mozilla.org/comm-central/source/mail/base/content/SearchDialog.js#567> says we don't support drag and drop in the thread pane. Is there a reason to keep messengerdnd.js?

I'd also like to either move messengerdnd.js to suite or get rid of it completely, but this is what I quickly came up with.
Assignee: nobody → sid.bugzilla
Status: NEW → ASSIGNED
Attachment #386129 - Flags: review?(mkmelin+mozilla)

Comment 2

9 years ago
That's odd. I'm pretty sure d'n'd from search worked at least in tb3beta2... 
Yeah thunderbird should get rid of messengerdnd.js.
(Reporter)

Comment 3

9 years ago
(In reply to comment #1)
> Created an attachment (id=386129) [details]
> possible fix

"possible", as in it's not clear this fixes it?
(Reporter)

Comment 4

9 years ago
(In reply to comment #2)
> That's odd. I'm pretty sure d'n'd from search worked at least in tb3beta2... 
> Yeah thunderbird should get rid of messengerdnd.js.

so then we won't need to care about bug 456156, bug 446292 and bug 446288?

Comment 5

9 years ago
(In reply to comment #3)
> "possible", as in it's not clear this fixes it?

As in get's rid of the exception, but dragging doesn't work.

Updated

9 years ago
Attachment #386129 - Flags: review?(mkmelin+mozilla) → review-

Comment 6

9 years ago
Comment on attachment 386129 [details] [diff] [review]
possible fix

Minusing per previous comments.
(Reporter)

Updated

9 years ago
Flags: blocking-thunderbird3?
(Assignee)

Comment 7

9 years ago
Created attachment 399094 [details] [diff] [review]
proper fix

Straightforward, and works nicely here.
Attachment #386129 - Attachment is obsolete: true
Attachment #399094 - Flags: review?(mkmelin+mozilla)

Comment 8

9 years ago
Comment on attachment 399094 [details] [diff] [review]
proper fix

yay! r=mkmelin
Attachment #399094 - Flags: review?(mkmelin+mozilla) → review+

Updated

9 years ago
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b4
(Assignee)

Comment 9

9 years ago
http://hg.mozilla.org/comm-central/rev/9b7f6edb75fa

Setting in-testsuite? since I hope we'll cover drag/drop in our test suite at some point in the future.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Filed bug 515397 about not shipping messengerdnd.js with Thunderbird.
(Reporter)

Comment 11

9 years ago
v.fixed 20090909 build. yay! again. Thanks sid.
Status: RESOLVED → VERIFIED
Flags: in-litmus?
(In reply to comment #0)

Are you sure this is related to (bug 497199 ->) bug 474701?

(In reply to comment #2)
> That's odd. I'm pretty sure d'n'd from search worked at least in tb3beta2... 

You sure? It looks like this occurrence was simply missed in bug 414038 comment 116?!
Blocks: 414038, 510793

Comment 13

9 years ago
I never verified which bug it's related to, but yeah iirc i verified it worked with beta2
Depends on: 500564
You need to log in before you can comment on or make changes to this bug.