The default bug view has changed. See this FAQ.

Stop allowing plugins to access XPCOM through NPN_GetValue()

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: cjones, Assigned: Josh Aas)

Tracking

(Blocks: 1 bug, {dev-doc-complete})

Trunk
dev-doc-complete
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Plugins can call NPN_GetValue() with the values NPNVserviceManager, NPNVDOMElement, or NPNVDOMWindow and get pointers to XPCOM instances.  They should not be able to do this.

Among other reasons that this interface is troublesome is that it will extremely painful to impossible for us to support when plugins run in separate processes.
And it prevents us from making any breaking changes to XPCOM.
(Assignee)

Updated

8 years ago
Assignee: nobody → joshmoz
(Assignee)

Updated

8 years ago
Version: unspecified → Trunk
(Assignee)

Comment 2

8 years ago
Do we have any known consumers besides maybe the old OJI-based Java plugin and maybe Real Player?
(Assignee)

Comment 3

8 years ago
Created attachment 385314 [details] [diff] [review]
fix v1.0
Attachment #385314 - Flags: superreview?(jst)

Updated

8 years ago
Attachment #385314 - Flags: superreview?(jst)
Attachment #385314 - Flags: superreview+
Attachment #385314 - Flags: review+
(Assignee)

Comment 4

8 years ago
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/7b55c4e84bcb
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 435433
Blocks: 435431
Depends on: 503902
Depends on: 510963
Duplicate of this bug: 531356

Updated

7 years ago
Depends on: 531290
Should we update https://developer.mozilla.org/en/NPN_GetValue
to mention that getting these values is deprecated in Firefox 3.6?
Keywords: dev-doc-needed
Documentation updated:

https://developer.mozilla.org/en/NPN_GetValue

Also mentioned on:

https://developer.mozilla.org/en/Firefox_3.6_for_developers#Miscellaneous
Keywords: dev-doc-needed → dev-doc-complete
Depends on: 545224
You need to log in before you can comment on or make changes to this bug.